Bug 149588 - [PATCH] Bad condition in mapping for latex2e
[PATCH] Bad condition in mapping for latex2e
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: linuxdoc-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 04:32 EST by Jindrich Novy
Modified: 2013-07-02 19:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.9.21-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 08:45:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to "mapping" file that fixes the issue. (1.03 KB, patch)
2005-02-24 04:34 EST, Jindrich Novy
no flags Details | Diff
Complete fix for all document classes in "mapping" and also for "tr-mapping" (8.56 KB, patch)
2005-02-24 11:11 EST, Jindrich Novy
no flags Details | Diff
Better patch (4.82 KB, patch)
2005-02-24 12:38 EST, Tomas Mraz
no flags Details | Diff

  None (edit)
Description Jindrich Novy 2005-02-24 04:32:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Description of problem:
sgml2latex generates pdf output even if --output=dvi option is passed to it. This is caused by the bad condition in mapping.

Version-Release number of selected component (if applicable):
linuxdoc-tools-0.9.21

How reproducible:
Always

Steps to Reproduce:
1. sgml2latex iproute/doc/ss.sgml
2. latex ss.tex [with teTeX-3.0]
3. output file is PDF instead of default DVI
  

Additional info:
Comment 1 Jindrich Novy 2005-02-24 04:34:00 EST
Created attachment 111368 [details]
Patch to "mapping" file that fixes the issue.
Comment 2 Tomas Mraz 2005-02-24 10:16:44 EST
This blocks correct rebuild of pam in RAWHIDE.
Comment 3 Tim Waugh 2005-02-24 10:36:35 EST
This fix is incomplete.  \ifpdf is used elsewhere in that file.
Comment 4 Tim Waugh 2005-02-24 10:39:05 EST
I've checked in a more complete fix -- please try 0.9.21-2.
Comment 5 Jindrich Novy 2005-02-24 11:06:43 EST
Tim, I just noticed that when testing it on pam. I've done a more complete fix.
I'll attach it also here.
Comment 6 Jindrich Novy 2005-02-24 11:11:35 EST
Created attachment 111382 [details]
Complete fix for all document classes in "mapping" and also for "tr-mapping"
Comment 7 Tim Waugh 2005-02-24 11:37:37 EST
Applied and built as 0.9.21-3.
Comment 8 Tomas Mraz 2005-02-24 12:27:55 EST
This is not right. The \ifx\pdfoutput\defined doesn't test for definition of
\pdfoutput, it's actually exactly the same as \ifx\pdfoutput\undefined. You've
just simply inverted the if condition and thus it will not generate pdf output
correctly. It will generate it but the conditions will not be evaluated as true
so the output will be different.
Comment 9 Tomas Mraz 2005-02-24 12:38:41 EST
Created attachment 111388 [details]
Better patch

This patch will work with both old and new tetex versions.
Comment 10 Tim Waugh 2005-02-24 12:46:43 EST
Thanks.  Okay, built as 0.9.21-4.
Comment 11 Radek Vokal 2005-02-25 04:23:09 EST
Fixes my problem with iproute build. Thanks
Comment 12 Jindrich Novy 2005-06-03 02:50:53 EDT
Tim, this problem is well known in upstream as well an they suggest the
following solution to this issue:

\ifx\pdfoutput\undefined
  <not running PDFTeX>
\else
  \ifx\pdfoutput\relax
    <not running PDFTeX>
  \else
    <running PDFTeX, with...>
    \ifnum\pdfoutput>0
      <...PDF output>
    \else
      <...DVI output>
    \fi
  \fi
\fi
Comment 13 Ondrej Vasik 2007-07-23 08:45:40 EDT
Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.