Bug 149596 - Enable FastCGI in standalone /usr/bin/php
Enable FastCGI in standalone /usr/bin/php
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
http://www.lighttpd.net/documentation...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 07:07 EST by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-05 11:30:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2005-02-24 07:07:46 EST
Hi,

I'm currently using lighttpd with PHP through FastCGI. It works
amazingly well, and lighttpd is now part of Fedora Extras. But in
order to have FastCGI support compiled in the /usr/bin/php standalone
binary (in addition to regular CGI which still works), one needs to
change the following in the spec file and rebuild :

 # Build standalone /usr/bin/php
 pushd build-cgi
-build --enable-force-cgi-redirect
+build --enable-force-cgi-redirect \
+      --enable-fastcgi \
+      --enable-discard-path \


Would it be possible to make this change to the main php package for
everyone to benefit from it and be able to use FastCGI out-of-the-box?
I don't know the exact implications or consequences regarding the
binary, but it still works fine from the command-line for me and
states that is has both CGI and FastCGI enabled. Also, there is no
possible consequence on the mod_php version, which is what the vast
majority of people use.
Comment 1 Matthias Saou 2005-03-30 07:00:05 EST
Joe, any idea if this change could be done before the next FC4 test release? If
it doesn't break anything, it would be really great to have it be in the default
build.
Comment 2 Joe Orton 2005-03-30 09:02:33 EST
I'm not really sure it's really appropriate to enable this by default, since we
don't ship a web server (or module) which can speak FastCGI in Core itself; it
looks like a fair chunk of extra code to build in.
Comment 3 Matthias Saou 2005-03-30 09:12:46 EST
But enabling software in Extras to play well with Core is something that is
wanted nevertheless, no? Especially since a FastCGI-enabled php in Extras is not
going to happen.

If this change affected mod_php in any way, I'd be much less keen on suggesting
it. But it affects only the standalone /usr/bin/php binary which very few people
use (I know I do only for a few cron jobs), but that many could start using if
it worked with FastCGI.
Comment 4 Matthias Saou 2005-04-25 04:54:34 EDT
Now that there are two separate standalone binaries (one for CLI, and the other
for CGI), wouldn't it be even safer to enable FastCGI in the CGI one?
Comment 5 Joe Orton 2005-04-25 06:31:04 EDT
Yes OK I submit :) I've enabled FastCGI support in /usr/bin/php-cgi in 5.0.4-7;
can you test it and let me know whether it works? I don't have a FastCGI setup
handy...

Note You need to log in before you can comment on or make changes to this bug.