Bug 1496153 - Extend DNF compatibility with YUM [NEEDINFO]
Summary: Extend DNF compatibility with YUM
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 27
Hardware: Unspecified Unspecified
high
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-26 14:47 UTC by Daniel Mach
Modified: 2018-06-28 08:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-28 08:21:10 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jmracek: needinfo? (dmach)


Attachments (Terms of Use)

Description Daniel Mach 2017-09-26 14:47:35 UTC
Existing YUM users are used to use 'yum' executable,
manage '/etc/yum.conf'
and read yum(8), yum-shell(8) and yum.conf(5) man pages.

We should provide them compat symlinks so they can find everything in usual places. Here's my brief analysis on what needs to be done:


Compat symlinks:

/etc/yum -> dnf
/etc/yum.conf -> dnf.conf
/usr/bin/yum -> dnf
/usr/share/doc/dnf -> yum
/usr/share/man/man5/yum.conf.5 -> dnf.conf.5
/usr/share/man/man8/yum-shell.8 -> dnf-shell.8
/usr/share/man/man8/yum.8 -> dnf.8


Keep as it is:

/etc/yum.repos.d


ToDo:

/etc/yum/vars


Drop:

/etc/logrotate.d/yum
(obsolete)

/etc/yum/*
(covered as part of /etc/yum -> dnf symlink)

/usr/lib/yum-plugins
(API changes -> incompatible plugins; we don't want to support this location for any longer)
 
/usr/share/bash-completion/completions/yum
/usr/share/bash-completion/completions/yummain.py
(bash completion replaced with DNF's)

/var/cache/yum/*
(cache, no need for a compat symlink)

/var/lib/yum/*
(data in incompatible format, we probably don't want this symlink either)

Comment 1 Jaroslav Mracek 2017-10-02 14:38:01 UTC
Do we really need /usr/share/doc/dnf -> yum ?

With /etc/yum -> dnf we have to keep in mind that some packages add protected packages configuration in "/etc/yum/protected.d/*.conf".

I also have to point out for /usr/share/man/man8/yum-shell.8 -> dnf-shell.8 that there is nothing like "dnf-shell.8*".

Comment 2 Jaroslav Mracek 2017-10-03 06:45:34 UTC
I create a patch, that provide most of requested features (https://github.com/rpm-software-management/dnf/pull/938).

Comment 3 Jaroslav Mracek 2018-06-28 08:21:10 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.