Bug 1496198 - 'Ceph - At A Glance - Capacity panel' missing units
Summary: 'Ceph - At A Glance - Capacity panel' missing units
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Unclassified
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: rc
: 3.0
Assignee: Paul Cuzner
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-26 15:57 UTC by Lubos Trilety
Modified: 2017-12-05 23:45 UTC (History)
8 users (show)

Fixed In Version: cephmetrics-1.0-2.el7cp
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-05 23:45:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 0 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Lubos Trilety 2017-09-26 15:57:39 UTC
Description of problem:
'Ceph - At A Glance' Capacity panel doesn't show any units. The panel shows only percentage of usage. From that it's not clear how much space is used/left.

Version-Release number of selected component (if applicable):
cephmetrics-1.0-1.el7cp.x86_64
cephmetrics-grafana-plugins-1.0-1.el7cp.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install cephmetrics
2. Look at Capacity panel on 'Ceph - At A Glance' dashboard
3.

Actual results:
Only percentage of usage is displayed

Expected results:
Hover on chart shows used size the same as 'Placement Group Status' panel chart do. There will be also information about total size.

Additional info:

Comment 1 Zack Cerza 2017-10-04 21:37:37 UTC
I don't think Grafana's singlestat panel supports this. The 'Placement Group Status' panel is a pie chart.

Comment 2 Paul Cuzner 2017-10-04 23:38:15 UTC
+1 The singlestat panel does not provide this feature. 

What we could do is link from the capacity gauge to the cluster dashboard that shows the bytes available used etc?

Comment 6 Lubos Trilety 2017-10-25 11:13:15 UTC
Tested with:
cephmetrics-1.0-6.el7cp.x86_64

The 'Ceph - At A Glance' Capacity panel is linked to Cluster Capacity panel. All other links go to some dashboard not panel, should not this one similarly goes to the 'Ceph Cluster' dashboard instead?

Comment 7 Paul Cuzner 2017-10-27 07:55:37 UTC
It does go to the dashboard, but auto zooms into the specific panel. You click on capacity and you get the capacity chart, press ESC and you see the dashboard.

Not sure what the problem is

Comment 8 Federico Lucifredi 2017-11-03 15:08:16 UTC
I am to keep current setup.

Comment 9 Lubos Trilety 2017-11-06 07:11:28 UTC
Tested with:
cephmetrics-1.0-7.el7cp.x86_64

With comment 8 in mind it works properly.

Comment 12 errata-xmlrpc 2017-12-05 23:45:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.