Bug 1496247 - SELinux is preventing dbus-daemon from read, write access on the сокет socket.
Summary: SELinux is preventing dbus-daemon from read, write access on the сокет socket.
Keywords:
Status: CLOSED DUPLICATE of bug 1496249
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:34a55d63421a1114a0357de0807...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-26 18:49 UTC by lonelywoolf
Modified: 2017-09-27 11:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-27 11:06:24 UTC
Type: ---


Attachments (Terms of Use)

Description lonelywoolf 2017-09-26 18:49:18 UTC
Description of problem:
SELinux is preventing dbus-daemon from read, write access on the сокет socket.

*****  Plugin catchall (100. confidence) suggests   **************************

If if you believe that dbus-daemon should be allowed read write access on the socket socket by default.
Then рекомендуется создать отчет об ошибке.
Чтобы разрешить доступ, можно создать локальный модуль политики.
Do
allow this access for now by executing:
# ausearch -c 'dbus-daemon' --raw | audit2allow -M my-dbusdaemon
# semodule -X 300 -i my-dbusdaemon.pp

Additional Information:
Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:system_r:init_t:s0
Target Objects                socket [ socket ]
Source                        dbus-daemon
Source Path                   dbus-daemon
Port                          <Неизвестно>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-288.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.14.0-0.rc1.git4.1.fc28.x86_64 #1
                              SMP Fri Sep 22 21:46:10 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-09-27 01:48:05 +07
Last Seen                     2017-09-27 01:48:05 +07
Local ID                      9edcfaf2-7a6f-4a5b-9ef4-ebe6d5d93729

Raw Audit Messages
type=AVC msg=audit(1506451685.360:132007): avc:  denied  { read write } for  pid=585 comm="dbus-daemon" path="socket:[1108649]" dev="sockfs" ino=1108649 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0 tclass=socket permissive=1


Hash: dbus-daemon,system_dbusd_t,init_t,socket,read,write

Version-Release number of selected component:
selinux-policy-3.13.1-288.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.2
hashmarkername: setroubleshoot
kernel:         4.14.0-0.rc1.git4.1.fc28.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2017-09-27 11:06:24 UTC

*** This bug has been marked as a duplicate of bug 1496249 ***


Note You need to log in before you can comment on or make changes to this bug.