Bug 1496308 - [config/type-ghostscript.xml.in] using outdated hardcoded paths for (URW)++ fonts
Summary: [config/type-ghostscript.xml.in] using outdated hardcoded paths for (URW)++ f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1496032
TreeView+ depends on / blocked
 
Reported: 2017-09-27 03:59 UTC by Michael Cronenworth
Modified: 2017-10-11 01:53 UTC (History)
5 users (show)

Fixed In Version: ImageMagick-6.9.9.15-1.fc27 ImageMagick-6.9.9.15-1.fc26 ImageMagick-6.9.9.15-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-04 14:21:51 UTC


Attachments (Terms of Use)

Description Michael Cronenworth 2017-09-27 03:59:23 UTC
Description of problem:
urw-fonts provided more fonts than urw-base35-fonts provides. At least Helvetica (and its derivatives) are known to be missing.

This causes test failures in ImageMagick, which requires a Helvetica font.


Version-Release number of selected component (if applicable):
urw-base35-fonts-20170801-1.fc28.noarch


See: https://github.com/ImageMagick/ImageMagick/issues/782


I think it is wrong to "Provides: urw-fonts" when you don't provide a replacement.


Where can I grab a Helvetica font for ImageMagick now?

Comment 1 David Kaspar [Dee'Kej] 2017-09-27 10:40:56 UTC
Hello Michael,

I was actually looking into this yesterday after my colleagu (Petr Pisar) told me about it, and wanted to create a BZ for it with a patch. And please note that the problem is not in the urw-base35-fonts, but in the ImageMagick itself. Here's why:

1) First of all, the 'urw-base35-fonts' actually *do provide* Helvetica font. Here's the relevant fontconfig file provided with that package:

----------------------------------------

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <!-- Generic name aliasing -->
  <alias>
    <family>sans-serif</family>
    <prefer>
      <family>Nimbus Sans</family>
    </prefer>
  </alias>

  <!-- Generic name assignment -->
  <alias>
    <family>Nimbus Sans</family>
    <default>
      <family>sans-serif</family>
    </default>
  </alias>

  <!-- Original PostScript base font mapping -->
  <alias binding="same">
    <family>Nimbus Sans</family>
    <default>
      <family>Helvetica</family>
    </default>
  </alias>

  <!-- Font substitution rules -->
  <alias binding="same">
    <family>Helvetica</family>
    <accept>
      <family>Nimbus Sans</family>
    </accept>
  </alias>

  <alias binding="same">
    <family>TeX Gyre Heroes</family>
    <accept>
      <family>Nimbus Sans</family>
    </accept>
  </alias>
</fontconfig>

----------------------------------------

As you can see, the 'urw-base35-fonts' are providing the Helvetica font substitution. (And it's actually the same font as before, but in newer version.)

2) The reason why the ImageMagick is not building is this file:
> ImageMagick-6.9.9-13/config/type-ghostscript.xml.in

If you look into this file, you will see this:
<type name="Helvetica" fullname="Helvetica Regular" family="Helvetica" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n019003l.afm" glyphs="@ghostscript_font_dir@n019003l.pfb"/>

The ImageMagick is not using the (URW)++ fonts directly (as it IMHO should), nor it is using fontconfig (which it IMHO should even more). It is using *outdated* file names for the fonts, taken from ghostscript.

Ghostscript, starting by version 9.20, is using new version of these fonts, with completely different file names. The 'urw-base35-fonts' fonts are the exact ones ghostscript is currently using for version 9.22, and was taken directly from repository maintained by ghostscript team (Artifex company).

->> As as result, this is a problem in ImageMagick, this is not a problem of 'urw-base35-fonts'.

I will help you prepare a patch to workaround this (with a necessary pull-request in upstream), I will update ghostscript package to point correctly to these new fonts (so the @ghostscript_font_dir@ will still work for this workaround), and I will suggest upstream to use (preferably) the fontconfig for locating relevant fonts, because there are many other fonts that can be used as Helvetica replacement (your support in this matter would be appreciated).

 -- Dee'Kej --

Comment 2 Michael Cronenworth 2017-09-27 13:01:31 UTC
Thanks, David.

Comment 3 David Kaspar [Dee'Kej] 2017-09-27 13:03:57 UTC
I have createa a patch for ImageMagick to (hopefully) fix this. I'm trying the build for Rawhide now...

Comment 4 Fedora Update System 2017-09-28 00:57:11 UTC
ImageMagick-6.9.9.15-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5a9805c5b

Comment 5 Fedora Update System 2017-09-28 00:57:56 UTC
ImageMagick-6.9.9.15-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-897a192750

Comment 6 Fedora Update System 2017-09-28 01:55:58 UTC
ImageMagick-6.9.9.15-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-66d9113c7a

Comment 7 Fedora Update System 2017-09-28 16:29:32 UTC
ImageMagick-6.9.9.15-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5a9805c5b

Comment 8 Fedora Update System 2017-09-29 00:54:39 UTC
ImageMagick-6.9.9.15-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-897a192750

Comment 9 Fedora Update System 2017-09-29 01:51:13 UTC
ImageMagick-6.9.9.15-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-66d9113c7a

Comment 10 Fedora Update System 2017-09-30 15:54:34 UTC
ImageMagick-6.9.9.15-1.fc27 rubygem-rmagick-2.16.0-7.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5a9805c5b

Comment 11 Fedora Update System 2017-09-30 16:01:49 UTC
ImageMagick-6.9.9.15-1.fc26 rubygem-rmagick-2.16.0-7.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-897a192750

Comment 12 Fedora Update System 2017-09-30 16:02:05 UTC
ImageMagick-6.9.9.15-1.fc25 rubygem-rmagick-2.16.0-7.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-66d9113c7a

Comment 13 Fedora Update System 2017-10-01 23:52:26 UTC
ImageMagick-6.9.9.15-1.fc26, rubygem-rmagick-2.16.0-7.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-897a192750

Comment 14 Fedora Update System 2017-10-02 00:53:57 UTC
ImageMagick-6.9.9.15-1.fc27, rubygem-rmagick-2.16.0-7.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5a9805c5b

Comment 15 Fedora Update System 2017-10-02 00:54:40 UTC
ImageMagick-6.9.9.15-1.fc25, rubygem-rmagick-2.16.0-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-66d9113c7a

Comment 16 David Kaspar [Dee'Kej] 2017-10-02 10:18:50 UTC
Michael, please make sure that the packages build against F26 and F25 are build against 'urw-fonts'.

The new package (urw-base35-fonts) landed in testing repository for F26 and F25 by mistake, and I do not expect the package to make it there at all (it was unpushed).

For F27 and Rawhide, we will be using the new urw-base35-fonts. :)

Thank you! :)

Comment 17 Michael Cronenworth 2017-10-02 17:08:12 UTC
According to the buildroot log the older package was used.

https://kojipkgs.fedoraproject.org//packages/ImageMagick/6.9.9.15/1.fc26/data/logs/x86_64/root.log

Comment 18 David Kaspar [Dee'Kej] 2017-10-02 17:19:35 UTC
Ah, okay, good to know. :) I'm not sure though, if there will be a rebuild required after the 'urw-base35-fonts' are released via Bodhi in F27... :-/

Comment 19 Fedora Update System 2017-10-04 14:21:51 UTC
ImageMagick-6.9.9.15-1.fc27, rubygem-rmagick-2.16.0-7.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2017-10-10 21:21:54 UTC
ImageMagick-6.9.9.15-1.fc26, rubygem-rmagick-2.16.0-7.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2017-10-11 01:53:42 UTC
ImageMagick-6.9.9.15-1.fc25, rubygem-rmagick-2.16.0-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.