Bug 1496338
| Summary: | [Doc] : Document "mon_allow_pool_delete" config option. | ||
|---|---|---|---|
| Product: | [Red Hat Storage] Red Hat Ceph Storage | Reporter: | Ambarish <asoman> |
| Component: | Documentation | Assignee: | John Wilkins <jowilkin> |
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Ambarish <asoman> |
| Severity: | high | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 3.0 | CC: | asriram, assingh, hnallurv, jowilkin, kdreyer |
| Target Milestone: | rc | ||
| Target Release: | 3.0 | ||
| Hardware: | x86_64 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2017-12-26 03:38:22 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | |||
| Bug Blocks: | 1496210 | ||
See https://gitlab.cee.redhat.com/red-hat-ceph-storage-documentation/doc-Red_Hat_Ceph_Storage_3-Configuration_Guide/commit/30115e426e78dfdea4e35af7b9cb2bf0918ab445 and see Comment 2 link. LGTM,Thanks John! Verified by QE. |
Description of problem: ----------------------- While running CBT , the script errored out with the following error message on stdout : <snip> Traceback (most recent call last): File "/home/ceph/cbt/cbt.py", line 71, in main b.run() File "/home/ceph/cbt/benchmark/radosbench.py", line 67, in run self.mkpools() File "/home/ceph/cbt/benchmark/radosbench.py", line 160, in mkpools self.cluster.rmpool('rados-bench-cbt', self.pool_profile) File "/home/ceph/cbt/cluster/ceph.py", line 636, in rmpool continue_if_error=False).communicate() File "/home/ceph/cbt/common.py", line 33, in communicate raise Exception(str(self)+'\nstdout:\n'+stdoutdata+'\nstderr\n'+stderrdata) Exception: checked_Popen args=['pdsh', '-S', '-f', '1', '-R', 'ssh', '-w', 'ceph@gqac016', 'sudo /usr/bin/ceph -c /tmp/cbt/ceph/ceph.conf osd pool delete rados-bench-cbt rados-bench-cbt --yes-i-really-really-mean-it'] continue_if_error=False rtncode=1 stdout: stderr gqac016: Error EPERM: pool deletion is disabled; you must first set the mon_allow_pool_delete config option to true before you can destroy a pool pdsh@gqac016: gqac016: ssh exited with exit code 1 </snip> This is a change introduced in CEPH 3.0 developer bits. For successful pool deletion,I think it's good to include this in the admin guide in appropriate places.