Bug 1496416 - Automated kickstart installation with GUI hangs on incomplete storage spoke (race condition).
Summary: Automated kickstart installation with GUI hangs on incomplete storage spoke (...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-27 11:14 UTC by Radek Vykydal
Modified: 2018-04-10 08:49 UTC (History)
3 users (show)

Fixed In Version: anaconda-21.48.22.125-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 08:47:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
anaconda.log (19.83 KB, text/plain)
2017-09-27 11:16 UTC, Radek Vykydal
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0671 None None None 2018-04-10 08:49:06 UTC

Description Radek Vykydal 2017-09-27 11:14:27 UTC
Description of problem:

During automatic kickstart installation in graphical mode the installation stops with Storage Spoke incomplete. After visiting the spoke and clicking Done the installation proceeds.

This is caused by a race condition:
Right before storage checking thread finishes, it updates status of the storage spoke to status ready sending message to the main thread. The main thread as a part of the ready message processing updates summary hub completeness based on checking the completeness of the storage spoke which is evaulated based on the storage checking thread, which in case of the race condition hasn't finished yet.

Note the minimal time interval between the thread and the spoke ready status reported (from anaconda.log).

05:13:43,559 DEBUG anaconda: Storage check finished with success.
05:13:43,560 INFO anaconda: Thread Done: AnaCheckStorageThread (139735677433600)
05:13:43,563 INFO anaconda: spoke is ready: StorageSpoke

Version-Release number of selected component (if applicable):

RHEL 7.4
nightlies of RHEL 7.5

How reproducible:

Not easy, I was hitting it consistently when running kickstart tests in kvm. Batch of ~20 tests, running 4 tests in parallel. Every ~2nd batch hit the problem. Another reproducer was reported here:
https://github.com/rhinstaller/anaconda/pull/1194

Steps to Reproduce:
1. Run fully automatic kickstart installation with GUI (I was using vnc).
2. Hit the race (or not)

Actual results:

The installation hangs in summary hub.

Expected results:

The installation completes automatically.

Additional info:

Comment 2 Radek Vykydal 2017-09-27 11:16:59 UTC
Created attachment 1331376 [details]
anaconda.log

Comment 3 Radek Vykydal 2017-09-27 11:18:26 UTC
https://github.com/rhinstaller/anaconda/pull/1198

Comment 9 errata-xmlrpc 2018-04-10 08:47:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0671


Note You need to log in before you can comment on or make changes to this bug.