Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1496430 - Different jars between rpm and zip
Summary: Different jars between rpm and zip
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: tomcat6, tomcat7
Version: 2.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 2.1.2-Bundle 2
Assignee: Coty Sutherland
QA Contact: Jan Onderka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-27 11:51 UTC by Jan Onderka
Modified: 2017-10-03 19:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-03 19:10:18 UTC
Type: Bug


Attachments (Terms of Use)
Differences between rpm and zip (2.34 KB, text/plain)
2017-09-27 11:51 UTC, Jan Onderka
no flags Details

Description Jan Onderka 2017-09-27 11:51:32 UTC
Created attachment 1331382 [details]
Differences between rpm and zip

Description of problem:
There are some differences between rpm and zip distribution in files tomcat-coyote.jar and catalina.jar
Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. install EWS from RPMs
2. install EWS from ZIP
3. check different jar files

Actual results:
difference in jar files, see attachment tomcat_differences.txt

Expected results:
no difference inside jar files

Additional info:
see tomcat_differences.txt

Comment 1 Michal Karm Babacek 2017-09-27 12:02:16 UTC
Isn't it actually expected?
RPM naturally contains just the diff since the last change, i.e. Bundle 1 -> Bundle 2, whereas zip distribution contains all the changes GA -> Bundle 1 -> Bundle 2 as it is a cumulative zip...

WDYT? Did you check that?


Note You need to log in before you can comment on or make changes to this bug.