Bug 149659 - rpm crash: unable to initialize mutex ; running as root
rpm crash: unable to initialize mutex ; running as root
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: basesystem (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-24 16:40 EST by Michael De La Rue
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 13:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael De La Rue 2005-02-24 16:40:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
When I run as root, rpm bombs out and does nothing (see message below).  When running as a normal user I can do normal queries of the database and see everything.  



Version-Release number of selected component (if applicable):
rpm-4.4.1-2

How reproducible:
Always

Steps to Reproduce:
1.  rpm -qa
2.
3.
  

Actual Results:  [root@ken ~]# rpm -qa
rpmdb: unable to initialize mutex: Function not implemented
rpmdb: /var/lib/rpm/__db.001: unable to initialize environment lock: Function not implemented
error: db4 error(38) from dbenv->open: Function not implemented
error: cannot open Packages index using db3 - Function not implemented (38)
error: cannot open Packages database in /var/lib/rpm


No further information printed.  

Expected Results:  list of all packages

Additional info:

I started with a FC3 system then did an upgrade to allow me to install xen.  The upgrade was repeated a couple of times.  

Build Date: Mon 14 Feb 2005 01:36:14 CET
Comment 1 Michael De La Rue 2005-02-24 16:41:21 EST
I plan to rebuild the system from zero soon, so if you want to get more data
out, mail me quick please.
Comment 2 Jeff Johnson 2005-03-03 06:53:50 EST
You appear to not have pthread support on your xen install system.

rpm expects functional pthread mutexes for locking. Xen
needs to provide an adequate environment to run rpm.
Comment 3 Michael De La Rue 2005-03-03 15:43:26 EST
I am not running xen when this bug is generated.  Even if I was, I
would be running RedHat's xen install, so it would still be a bug
(though possibly not your bug).  
Comment 4 Jeff Johnson 2005-03-03 18:23:25 EST
For whatever reason, you system is failing to initialize
a posix mutex. This needs to be addressed by you, not as
an rpm bug, which it is not.
Comment 5 Michael De La Rue 2005-03-06 13:36:40 EST
okay, so the bug is quite simple; the libraries in /lib/tls were
missing.  RPM or, possibly more likely rpmdb, is failing to open a
library that it needs.

Instead of noticing that it can't load the library, and issuing a
warning to the user, rpm is masking the failures (it has 40 separate
failures loading libraries from /lib/tls alone) and simply issuing the
above warning.  

Based on past discussions about whether RPM should issue clear error
messages etc. I'm setting this to WONTFIX
Comment 6 vace 2005-03-07 15:04:44 EST
This is probably being caused by an
LD_ASSUME_KERNEL=2.2.5.  I used to need
it for rpm for some reason I forget now.  
Removing it fixes the problem with the
mutex and a whole bunch of other faults
in rpm.  I hope this helps.

Note You need to log in before you can comment on or make changes to this bug.