Bug 149664 - install scripts create $HOME/.mozilla (and shouldn't)
Summary: install scripts create $HOME/.mozilla (and shouldn't)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-02-24 22:01 UTC by Matthew Miller
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-13 20:58:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Miller 2005-02-24 22:01:20 UTC
Description of problem:

When you install the firefox RPM, it creates a .mozilla directory in your
homedir if you didn't have one there already. This is particularly noticable
when installing via sudo, as you end up with a root-owned ~/.mozilla in your own
home directory, which obviously breaks stuff. (If you install when logged in as
root, you'll get /root/.mozilla.)

RPMs shouldn't have user-directory side effects like this.


Version-Release number of selected component (if applicable):

Happens in FC3 0.10.1-1.0PR1.20 and in current rawhide 1.0-8. Not sure when it
started.

How reproducible:

Always

Steps to Reproduce:
1. rm -rf ~/.mozilla
2. sudo rpm -Uvh firefox-1.0-8.i386.rpm
3. ls -ld ~/.mozilla
  
Actual results:

drwx------  2 root root 4096 Feb 24 17:00 .mozilla/

Expected results:

ls: ~/.mozilla: No such file or directory

Comment 1 Matthew Miller 2005-02-26 05:10:30 UTC
FWIW, the 1.0.1-1.3.1 package does this too.

Comment 2 Jeremy Katz 2005-04-28 01:00:13 UTC
Could work around by putting HOME=/root in the %post

Comment 3 Christopher Aillon 2005-05-09 17:53:17 UTC
Checked in a slightly different version of the workaround, using %{_tmppath}
instead.  firefox-1.0.3-5 and thunderbird-1.0.2-4 have the fix (though
thunderbird is not building because of gcc/ppc issues currently)

Comment 4 Matthew Miller 2005-05-10 13:43:37 UTC
Hi Christopher. I don't think that'll work properly, since %{_tmppath} is
expanded at RPM build time, not when %post is run. So it ends up being 

HOME=/usr/src/build/564449-i386/install-tmp /usr/lib/firefox-1.0.3/firefox -register

in the rawhide binary package, or /home/mattdm/tmp if I build the package using
my personal setup.

Comment 5 Christopher Aillon 2005-05-13 20:58:44 UTC
Ok, better solution using `mktemp -d` in place.

Comment 6 Matthew Miller 2005-05-13 21:15:31 UTC
thanks!


Note You need to log in before you can comment on or make changes to this bug.