Bug 149667 - lack of dhcp hostname
lack of dhcp hostname
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-02-24 17:16 EST by Casey Boone
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.08-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 16:27:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Casey Boone 2005-02-24 17:16:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040910 MultiZilla/1.6.4.0b

Description of problem:
with all versions of redhat linux i have used starting with 7 and
continuing until fc3 there is a rather poor behavior with how the
network initialization scripts handle handing off a hostname to the
dhcp server.

currently they only check to see if ifcfg_<interfacename> has a value
of DHCP_HOSTNAME assigned and if not, they do not pass a hostname to a
dhcp client request for that interface.

i believe that a more sane behavior would be to check for the
existance of this value, if it isnt present then use the current
system hostname (obtained from running hostname) instead.  there are
many isps whose dhcp server will not reply without a hostname in the
request.  i see no security concerns over pushing the system's own
hostname out with the request (and for those who think there is, then
use the DHCP_HOSTNAME setting in ifcfg_<interfacename> to override.  i
am also not aware of any dhcp server which doesnt reply if a hostname
is present.

obviously this would be for machines in which the admin wants a static
hostname and not cases where the hostname gets assigned to the machine
via dhcp.

i can provide a fix if needed, however it should be rather trivial.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install fc3 with manually assigned hostname but dhcp assigned
network cards
2. reboot the machine/ifdown-ifup/services network restart/etc....


Actual Results:  hostname will NOT be sent to dhcp server until
DHCP_HOSTNAME is added to ifcfg_<ifname> file.

Expected Results:  machine's hostname should be sent instead unless
machine gets its hostname from the dhcp server

Additional info:

i do consider this to be a bug if only because i consider it to be a
design flaw.
Comment 1 Bill Nottingham 2005-04-15 16:27:36 EDT
Done in 8.08-1.
Comment 2 Bill Nottingham 2005-04-21 15:53:52 EDT
After discussion with the DHCP maintainer, his opinion was that this can cause
more new problems to pop up than it would solve. Reverting.

Note You need to log in before you can comment on or make changes to this bug.