Bug 1496692 - [ceph-ansible] - value set for 'ceph_repository_type' as iso is getting ignored
Summary: [ceph-ansible] - value set for 'ceph_repository_type' as iso is getting ignored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 3.0
Assignee: Sébastien Han
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-28 07:17 UTC by Vasishta
Modified: 2017-12-05 23:46 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.0-0.1.rc12.el7cp Ubuntu: ceph-ansible_3.0.0~rc12-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-05 23:46:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 1949 0 None closed ceph-common: Fix logic for ceph_repository_type 2020-12-07 09:22:23 UTC
Red Hat Product Errata RHBA-2017:3387 0 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Vasishta 2017-09-28 07:17:55 UTC
Description of problem:

While trying to set-up cluster using iso, playbook failed in task - verify that a repository type was chosen for ceph rhcs version saying - choose between 'cdn' or 'iso' installation, e.g: ceph_repository_type: cdn.\nValid ceph_repository_type are: [u'cdn', u'iso']" even though respective variable in all.yml has been set to appropriate value.

Version-Release number of selected component (if applicable):
ceph-ansible-3.0.0-0.1.rc11.el7cp.noarch

How reproducible:
Always (3/3)

Steps to Reproduce:
1. Configure ceph-ansible to get a cluster up using an iso image
2. Run playbook

Actual results:
choose between 'cdn' or 'iso' installation, e.g: ceph_repository_type: cdn.\nValid ceph_repository_type are: [u'cdn', u'iso']"

Expected results:
Ansible should be able to configure cluster using iso image

Additional info:
******************
As informed by the Sebastien, dev team has fixed this issue and will be available for testing in ceph-ansible version *rc12* (upcoming version). 
This BZ has been filed to ease the tracking.
******************

Comment 6 Vasishta 2017-10-10 14:49:23 UTC
Working fine, moving to VERIFIED state.

verified using - 
RHEL - ceph-ansible-3.0.0-0.1.rc15.el7cp.noarch.rpm 
Ubuntu- 3.0.0~rc19-2redhat1

Comment 9 errata-xmlrpc 2017-12-05 23:46:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.