Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1496713 - nautilus-desktop crashes when accessing properties of image file
nautilus-desktop crashes when accessing properties of image file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
:
: 1474848 (view as bug list)
Depends On:
Blocks: 1477211
  Show dependency treegraph
 
Reported: 2017-09-28 04:07 EDT by Rik Theys
Modified: 2018-05-17 10:39 EDT (History)
12 users (show)

See Also:
Fixed In Version: nautilus-3.22.3-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 09:04:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image that triggers this issue (954.60 KB, image/jpeg)
2017-09-28 04:07 EDT, Rik Theys
no flags Details
Add missing xmp_init() to nautilus-desktop main() (1.42 KB, patch)
2017-10-06 06:30 EDT, Nikola Forró
no flags Details | Diff
Patch to apply to the spec for rhel-7.5 (3.43 KB, patch)
2017-11-02 15:24 EDT, Carlos Soriano
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 09:05 EDT

  None (edit)
Description Rik Theys 2017-09-28 04:07:20 EDT
Created attachment 1331822 [details]
image that triggers this issue

Description of problem:

The nautilus desktop crashes when a users right clicks on an image that is stored on the desktop and selects properties.

The first time, the icons on the desktop are gone and come back after a second or so. The second time, the entire desktop session crashes.

[44195.865596] nautilus-deskto[17559]: segfault at 10 ip 00007fe21593a890 sp 00007fffee03c388 error 4 in libexempi.so.3.2.2[7fe2158b5000+115000]

This looks similar to the bug reported in the ubuntu bug tracker:

https://bugs.launchpad.net/ubuntu/+source/exempi/+bug/330557

According to that report, it should be fixed in 2.1.1, so it may still be another bug.


Version-Release number of selected component (if applicable):
exempi-2.2.0-8.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log in on the default gnome session of RHEL 7.4
2. Copy a png or jpg file to your ~/Desktop
3. Right-click the file and select properties
4. Repeat step 3

Actual results:
GNOME session crashes after doing it twice

Expected results:
Dialog that shows the properties of the image.


Additional info:
In case this bug depends on the content of the image file, in attach an image that easily reproduces the issue here.
Comment 2 Nikola Forró 2017-10-06 06:29:52 EDT
This needs to be fixed in Nautilus. It crashes because exempi is not initialized.
Comment 3 Nikola Forró 2017-10-06 06:30 EDT
Created attachment 1335204 [details]
Add missing xmp_init() to nautilus-desktop main()
Comment 4 Oliver Haessler 2017-10-26 04:20:44 EDT
Do we have any idea when an update will be available for RHEL 7?
Comment 5 Carlos Soriano 2017-10-26 09:50:46 EDT
Thanks Nikola for the patch, it looks good. We have a similar fix upstream.

Regarding 7.4, it depends on product management approval. I'm happy to apply patch + build if you manage to convince product management.
Comment 6 Carlos Soriano 2017-11-02 15:24 EDT
Created attachment 1347103 [details]
Patch to apply to the spec for rhel-7.5
Comment 7 Carlos Soriano 2017-11-02 15:24:56 EDT
Scratch build with the patch: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14450852
Comment 8 Carlos Soriano 2017-11-02 15:25:45 EDT
Now it's up to you to convince pm to have this in the version you want :)
Comment 10 Carlos Soriano 2017-11-30 07:50:42 EST
Hey Vinay, here is a new one. https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14653925
Comment 11 Carlos Soriano 2017-11-30 07:51:03 EST
It's based on rhel 7.5, but it shouldn't be a problem
Comment 13 zosy 2018-01-05 02:21:33 EST
same issue here in centos 7.4.1708, hope to fix it .
Comment 14 Nikola Forró 2018-01-29 10:58:26 EST
*** Bug 1474848 has been marked as a duplicate of this bug. ***
Comment 15 Michal Odehnal 2018-01-30 03:03:33 EST
(In reply to Nikola Forró from comment #3)
> Created attachment 1335204 [details]
> Add missing xmp_init() to nautilus-desktop main()

Scratch build with this patch fixes the issue for me.
Comment 20 errata-xmlrpc 2018-04-10 09:04:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.