Bug 1496732 - [modularity] Error: No such module on update locked module
Summary: [modularity] Error: No such module on update locked module
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-28 09:07 UTC by Irina Gulina
Modified: 2018-06-28 08:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-22 09:12:47 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Irina Gulina 2017-09-28 09:07:31 UTC
Description of problem:

If one tries to update locked module, the "Error: No such module" is displayed, which is not true.

Version-Release number of selected component (if applicable):
dnf-2.6.5-1.git.102.e0caca2.fc27.noarch

How reproducible:
always

Steps to Reproduce:
>> dnf module lock httpd
Loading repositories.
Last metadata expiration check: 2:37:09 ago on Thu 28 Sep 2017 06:11:14 AM UTC.
'httpd' is locked (stream: master, version: 20170905144343)

>> dnf module list --installed | grep httpd 
httpd           master (default) 20170905144343 (locked)                                 default   httpd module   
                              
>> dnf module update httpd
Loading repositories.
Last metadata expiration check: 2:41:56 ago on Thu 28 Sep 2017 06:11:14 AM UTC.
Error: No such module: httpd

>> dnf module list --installed | grep httpd
httpd           master (default) 20170905144343 (locked)                                 default   httpd module  

Expected results:
I believe a message similar to "Module <name> is locked and can't be updated" will be more realistic.

Comment 1 Irina Gulina 2017-09-28 10:36:53 UTC
In other words, I would expect VersionLockedException instead of NoModuleException

Comment 2 Martin Hatina 2017-10-04 11:02:58 UTC
Fixed by https://github.com/rpm-software-management/dnf/pull/939

Comment 3 Jaroslav Mracek 2018-06-28 08:07:08 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.