Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1496758 - Preserve storage configure values in logging-es deploymentconfig
Preserve storage configure values in logging-es deploymentconfig
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.7.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.9.0
Assigned To: ewolinet
Anping Li
logging
: NeedsTestCase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-28 06:09 EDT by Anping Li
Modified: 2018-03-28 10:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: We weren't preserving the storage type for ES dcs when upgrading/rerunning Consequence: The existing storage type would be overwritten. Fix: We now use preserve the storage type as a default (will use an inventory variable if specified). Result: We see the configured storage values preserved when not specifying a storage type during upgrade.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-28 10:07:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 10:07 EDT

  None (edit)
Description Anping Li 2017-09-28 06:09:58 EDT
Description of problem:
if we use local storage for ES storage folowing [1],  the hostpath [2] will be added to deploymentconfig. For the upgrade playbook remove the hostpath , the user has to add it back mannuly. that is an extend request as https://bugzilla.redhat.com/show_bug.cgi?id=1478771 to persist ES storage configuration in deploymentconfig

Version-Release number of the following components:
openshift-ansible


How reproducible:
always

Steps to Reproduce:
1. use local storage for ES storage following [1].  and save the deploymentconfig file
   oc get dc logging-es-data-master-xxxxx1 -o yaml > config.save1
2. upgrade logging and save the deploymentconfig file
   oc get dc logging-es-data-master-xxxxx2 -o yaml > config.save2
3. diff config.save1 config.save2

Actual results:
The hostPath[2] are deleted.

Expected results:
The storage configure values are perserved.

Additional info:
[1]https://docs.openshift.com/container-platform/3.5/install_config/aggregate_logging.html-> Persistent Elasticsearch Storage. 
[2]- hostPath:
          path: /usr/local/es-storage
        name: elasticsearch-storage
Comment 2 Jeff Cantrill 2018-01-15 15:09:09 EST
@Eric,

The work you did to preserve settings from DC's, does that include storage?  I thought we had logic to preserve host storage
Comment 4 Jeff Cantrill 2018-01-16 14:56:55 EST
Do you have specific source and target version for us to investigate?
Comment 8 Anping Li 2018-02-09 08:02:42 EST
Verified and pass with openshift-ansible-3.9.0-0.41.0.git.0.8290c01.el7.noarch
Comment 11 errata-xmlrpc 2018-03-28 10:07:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489

Note You need to log in before you can comment on or make changes to this bug.