Bug 1496777 - Deleting nodes assigned to deployment plan (failed or completed successfully) should not be possible
Summary: Deleting nodes assigned to deployment plan (failed or completed successfully)...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jiri Tomasek
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-28 11:53 UTC by Ola Pavlenko
Modified: 2019-05-16 16:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-16 16:04:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ola Pavlenko 2017-09-28 11:53:22 UTC
Description of problem:
Deleting nodes assigned to deployment plan (failed or completed successfully) should not be possible

Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.4.1-0.20170911164240.16684db.el7ost.noarch

How reproducible:
always

Steps to Reproduce:
1.register, intropect nodes using CLI 
2.and provide using UI
3. attempt to deploy an overcloud via CLI
openstack overcloud deploy --templates \
--libvirt-type kvm \
-e /home/stack/rhos12.yaml \
-e /home/stack/customization.yaml
4. try to delete nodes are used in the deployment 

Actual results:
Nodes were deleted
Expected results:
Deleting nodes used in a deployment, failed or successful, should not be possible

Additional info:

Comment 1 Beth White 2017-10-04 14:50:34 UTC
Functionality for this is currently not in place - if you delete a node it is not actually deleted but unregistered with ironic. The problem will be tracking possible actions on different nodes based on their state and this is not in the UI at all. Deleting of the nodes is handled directly through the ironic API. Therefore changing this to an RFE and triaging for OSP14. This is not a regression as this state was still there in previous releases. Therefore also removing blocker status.

Comment 4 Jason E. Rist 2018-08-06 14:25:40 UTC
Changing to a bug since this also effects OpenShift on OpenStack.

Comment 6 Beth White 2019-05-16 16:04:41 UTC
The GUI is no longer supported in OSP14. The last supported release for the GUI is OSP13. Closing as won't fix.


Note You need to log in before you can comment on or make changes to this bug.