Bug 149678 - Fills the logs with entries
Summary: Fills the logs with entries
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: mrtg   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-24 23:46 UTC by Mike Poublon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-25 00:01:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
startup script for /etc/init.d/ (865 bytes, text/plain)
2005-02-24 23:50 UTC, Mike Poublon
no flags Details

Description Mike Poublon 2005-02-24 23:46:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
The default configuration of mrtg uses cron to run. Each time that 
mrtg runs it makes an entry in /var/log/messages. Since mrtg runs 288 
times (24 hours * 12 times per hour) every day this adds up quickly 
and can make analyzing the log file more difficult. This can be 
solved by adding 

RunAsDaemon: Yes
Interval:    5

to /etc/mrtg/mrtg.cfg as well as making a startup file in /etc/init.d/

I believe this would make a better default configuration.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
install mrtg

Additional info:

Comment 1 Mike Poublon 2005-02-24 23:50:21 UTC
Created attachment 111417 [details]
startup script for /etc/init.d/

Comment 2 Miloslav Trmač 2005-02-25 00:01:40 UTC
The default configuration is that mrtg does nothing at all;
running an additional daemon that does nothing is somewhat a waste.

Another issue is that it would be quite hard to automatically
migrate from the cron setup (including users editing
/etc/cron.d/mrtg, changing the rule or even the command) to
the init.d setup.

Finally, the 288 entries in /var/log/cron a day are easy to
filter out using grep.

Taken together, I don't think this change is worth it... sorry.


Note You need to log in before you can comment on or make changes to this bug.