Bug 1496893 - Fail host deploy process if ovirt-host-deploy role is not found
Summary: Fail host deploy process if ovirt-host-deploy role is not found
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.2.0
Hardware: All
OS: All
low
medium
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Ondra Machacek
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-28 17:53 UTC by eraviv
Modified: 2018-02-12 10:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 10:10:50 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
engine log (966.35 KB, text/plain)
2017-10-02 10:30 UTC, eraviv
no flags Details
host deploy log (1.09 MB, text/plain)
2017-10-02 10:31 UTC, eraviv
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 82488 0 master MERGED core: Fail host install if playbook isn't found 2020-02-13 15:54:09 UTC

Description eraviv 2017-09-28 17:53:15 UTC
Description of problem:
When using firewalld cluster without installing ovirt-ansible, host vdsm is unreachable from engine, but there is no notification to the user in the admin portal.

Version-Release number of selected component (if applicable):
4.2.0 master

How reproducible:
100%

Steps to Reproduce:
1. install engine in dev env
2. run engine
3. create a host on engine 
==> after initial setup of vdsm on host is finished and engine tries to connect to vdsm on host, vdsm is unreachable because the firewall has not been configured (if firewalld is stopped host vdsm becomes reachable from host).

Actual results:
There is no event or notification in the admin portal that indicates why the status of the host has become unreachable.

Expected results:
event indicating problem should be written to the admin portal, and significant status should be displayed in the hosts table view

Additional info:

Comment 1 Oved Ourfali 2017-09-29 12:31:48 UTC
As far as I understand such a use case isn't possible when installing oVirt properly. Am I right?

Perhaps the Dev environment Readme should be improved to make sure you install new required packages.

Comment 2 eraviv 2017-10-02 10:25:42 UTC
on a clean 4.2 customer installation, I believe that ovirt-ansible would be installed, and this precise bug would not be seen. I am less sure about upgrades.

However, if Ansible fails for whatever reason, add-host should report a failure. Currently it is failing silently.

The Dev Readme is now up to date.


Attaching relevant logs

2017-09-27 13:34:32,049+03 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.EE-ManagedThreadFactory-engine-Thread-1) [7379abf9] EVENT_ID: VDS_ANSIBLE_INSTALL_STARTED(560), Ansible host-deploy playbook execution has started on host h-local-1.
2017-09-27 13:34:32,050+03 WARN  [org.ovirt.engine.core.common.utils.ansible.AnsibleExecutor] (org.ovirt.thread.EE-ManagedThreadFactory-engine-Thread-1) [7379abf9] Playbook '/home/eraviv/ov/dep/ovirt-engine-1/share/ovirt-engine/../ovirt-ansible-roles/playbooks/ovirt-host-deploy.yml' does not exists. Playbook won't be executed.
2017-09-27 13:34:32,054+03 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.EE-ManagedThreadFactory-engine-Thread-1) [7379abf9] EVENT_ID: VDS_ANSIBLE_INSTALL_FINISHED(561), Ansible host-deploy playbook execution has successfully finished on host h-local-1.

Comment 3 eraviv 2017-10-02 10:30:33 UTC
Created attachment 1333177 [details]
engine log

Comment 4 eraviv 2017-10-02 10:31:27 UTC
Created attachment 1333178 [details]
host deploy log

Comment 5 Martin Perina 2017-10-02 11:16:10 UTC
ovirt-engine depends on ovirt-ansible-roles package, so in RPM installation the ovirt-host-deploy role should always be present, but you are right, we should fail the host deploy process if the role is for example removed by accident.

Comment 6 Pavol Brilla 2018-01-17 11:30:00 UTC
Playbooks became part of ovirt-engine-tools.rpm and it depends on main ovirt-engine.rpm 

Not an issue anymore

Comment 7 Pavol Brilla 2018-01-17 11:30:38 UTC
Playbooks became part of ovirt-engine-tools.rpm and it depends on main ovirt-engine.rpm 

Not an issue anymore

Comment 8 Sandro Bonazzola 2018-02-12 10:10:50 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.