Bug 149699 - kernel panic 2.6.9-5.0.3, possible SATA problem?
kernel panic 2.6.9-5.0.3, possible SATA problem?
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: David Milburn
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-25 10:18 EST by Sam Sharpe
Modified: 2009-07-27 17:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 17:12:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sam Sharpe 2005-02-25 10:18:02 EST
Description of problem:

Kernel panics randomly on reboot. Suspect problem with SATA and/or ICH
drivers. Machines are all Dell Dimension 8{3,4}00s with an ICH
chipset. Have seen it on one SATA machine so far, and one PATA machine
(could be unrelated). We have RHEL4 installed on many near-identical
i686 machines with a combination of SATA/PATA, and are seriously
worried that this problem will begin to affect more than just a few
machines.

Looking at bugzilla, several bugs are filed against Fedora Core3 with
a similar kernel (2.6.9-681) - not all of these bugs are marked as
resolved, and seem to indicate a more general problem with sata in 2.6

Version-Release number of selected component (if applicable):

kernel-2.6.9-5*

How reproducible:

Problem is not 100% reproducible, seems slightly random because
machines can be rebooted and work fine for a while, then upon reboot
panic again.

Steps to Reproduce:
1. Install RHEL4 kernel 2.6.9-5.0.3
2. Reboot
  if != panic, repeat step 2

  
Actual results:

Kernel Panics
----------------------
Call Trace:
[<0222dd34>] pci_bios_find_device+0x1d/0x3e
...
[<021041d9>] kernel_thread_helper+0x5/0xb

Code: 2e 8a 83 96 04 00 00 66 5b 8a d8 66 58 c3 00 01 02 03 04 05
<0>Kernel Panic: Attempted to kill init!

Expected results:

Normal Boot.

Additional info:

lspci output
-------------------------------------
[pdm@circuit ~]$ /sbin/lspci -v|grep ICH
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI 
Controller #1 (rev 02) (prog-if 00 [UHCI])
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI 
Controller #2 (rev 02) (prog-if 00 [UHCI])
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 
(rev 02) (prog-if 00 [UHCI])
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI 
Controller #4 (rev 02) (prog-if 00 [UHCI])
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI 
Controller (rev 02) (prog-if 20 [EHCI])
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Interface 
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) IDE 
Controller (rev 02) (prog-if 8a [Master SecP PriP])
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) SATA Controller (rev 
02) (prog-if 8f [Master SecP SecO PriP PriO])
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller
(rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) 
AC'97 Audio Controller (rev 02)
Comment 1 Sam Sharpe 2005-02-25 10:20:43 EST
Incidently, our University has a large number of similar systems which
are due to be upgraded to RHEL4. If these random panics become more
prevalent, it will seriously impact our RHEL4 rollout.
Comment 3 David Milburn 2009-07-27 17:12:40 EDT
I have installed RHEL4 U8 to an ICH5/ICH5R system and did not encounter problems
running IO stress test, please re-open if you can reproduce this on a 2.6.9-89
kernel.

Note You need to log in before you can comment on or make changes to this bug.