Bug 1496993 - Unable to fetch from git
Summary: Unable to fetch from git
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-28 22:08 UTC by Vijay Bellur
Modified: 2017-09-29 19:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-29 19:38:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijay Bellur 2017-09-28 22:08:06 UTC
Description of problem:


git pull on my glusterfs / gluster-block repos fail with the following error:

Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Here's output of `git remote -v`

origin	ssh://vbellur@review.gluster.org/glusterfs.git (fetch)
origin	ssh://vbellur@review.gluster.org/glusterfs.git (push)
public	git@github.com:gluster/glusterfs.git (fetch)
public	git@github.com:gluster/glusterfs.git (push)


Additional info:

Been noticing this problem since the beginning of this week. Tried deleting and adding the same dsa key in r.g.o but that doesn't seem to help.

Comment 1 Nigel Babu 2017-09-29 17:54:13 UTC
The gerrit logs actually say wrong key. I don't know what's going on here. We haven't touched anything from the server end.

Here are the options:
* Verify that the public key completely matches the private key. `ssh-keygen -y -e -f /path/to/private/key` will print out the public key. Makes sure it matches what's on bugzilla.
* Try generating an entirely new key and attempt to login to review.gluster.org with that.
* As a workaround, attempt using the HTTPS protocol temporary for push and pulls. You'll need to generate an HTTP password here: https://review.gluster.org/#/settings/http-password

Comment 2 Vijay Bellur 2017-09-29 19:38:45 UTC
Thank you, Nigel!

It is probably related to my dsa key. I setup a new rsa public key and that's working well now.

Perhaps, gerrit no longer supports dsa auth?


Note You need to log in before you can comment on or make changes to this bug.