Bug 1497045 - Installing OS failed on fc direct lun disk
Summary: Installing OS failed on fc direct lun disk
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: pre-dev-freeze
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: ovirt-node-ng-43-el76-platform
TreeView+ depends on / blocked
 
Reported: 2017-09-29 05:47 UTC by dguo
Modified: 2018-10-11 08:05 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-11 08:05:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
installing failed logs on the vm (8.14 MB, application/x-gzip)
2017-09-29 05:47 UTC, dguo
no flags Details
engine side logs (70.94 KB, application/x-gzip)
2017-09-29 05:48 UTC, dguo
no flags Details

Description dguo 2017-09-29 05:47:37 UTC
Created attachment 1332217 [details]
installing failed logs on the vm

Description of problem:
Installing OS failed on the vm with a fc direct lun disk 

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.7.2-0.1.el7
rhvh-4.1-0.20170927.0+1
vdsm-4.19.33-1.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Adding a fresh installed host to engine
2.Create a vm and attach a direct fc lun
3.Installing os to this vm via anaconda UI

Actual results:
After configure ("Network" "Storage" "Timzone" etc) on anaconda UI , Click Begin installation,  later will catch the "FormatCreateError: ('format failed: 1', '/dev/sda1')" on the UI

Expected results:
OS can be successfully installed

Additional info:
1.With the same engine and host version as above mentioned, OS can be installed to direct iscsi lun, thus only can be caught on fc lun.

Comment 1 dguo 2017-09-29 05:48:23 UTC
Created attachment 1332218 [details]
engine side logs

Comment 2 Moran Goldboim 2017-10-02 08:47:48 UTC
Daijie, is this bug a regression from 4.1.6?
Thanks.

Comment 3 dguo 2017-10-09 10:14:19 UTC
(In reply to Moran Goldboim from comment #2)
> Daijie, is this bug a regression from 4.1.6?
> Thanks.

Hi Moran,
Just back from vacation. I did more test on 4.1.6 or before, found the issue can be reproduced 100% with the specified OS(CentOS 7.3) which being installed to the vm. While changed the OS to another(ovirt-node-4.2-pre), the OS could be successfully installed. Guess this might be related with anaconda. 
Thus, suggest to close this bug for vdsm.

Thanks

Comment 4 Allon Mureinik 2017-10-15 10:41:56 UTC
> (In reply to Moran Goldboim from comment #2)
> > Daijie, is this bug a regression from 4.1.6?
> > Thanks.
> 
> Hi Moran,
> Just back from vacation. I did more test on 4.1.6 or before, found the issue
> can be reproduced 100% with the specified OS(CentOS 7.3) which being
> installed to the vm. While changed the OS to another(ovirt-node-4.2-pre),
> the OS could be successfully installed. Guess this might be related with
> anaconda. 
> Thus, suggest to close this bug for vdsm.
Agreed - moving the bz to anaconda to see if they wish to follow up or not.

Comment 6 Samantha N. Bueno 2017-10-27 08:09:26 UTC
From program.log:
13:17:52,297 INFO program: mkfs.xfs: libxfs_device_zero write failed: Input/output error
13:17:52,299 INFO program: meta-data=/dev/sda1              isize=256    agcount=4, agsize=32000 blks
13:17:52,299 INFO program:          =                       sectsz=512   attr=2, projid32bit=1
13:17:52,300 INFO program:          =                       crc=0        finobt=0
13:17:52,302 INFO program: data     =                       bsize=4096   blocks=128000, imaxpct=25
13:17:52,303 INFO program:          =                       sunit=0      swidth=0 blks
13:17:52,303 INFO program: naming   =version 2              bsize=4096   ascii-ci=0 ftype=0
13:17:52,304 INFO program: log      =internal log           bsize=4096   blocks=853, version=2
13:17:52,305 INFO program:          =                       sectsz=512   sunit=0 blks, lazy-count=1
13:17:52,306 INFO program: realtime =none                   extsz=4096   blocks=0, rtextents=0
13:17:52,306 DEBUG program: Return code: 1

And from syslog:
05:17:50,397 INFO kernel:[   82.025337]  sda: unknown partition table
05:17:50,853 INFO kernel:[   82.481308]  sda:
05:17:51,260 INFO kernel:[   82.888753] sd 2:0:0:0: [sda] FAILED Result: hostbyte=DID_OK driverbyte=DRIVER
_SENSE
05:17:51,260 INFO kernel:[   82.888780] sd 2:0:0:0: [sda] Sense Key : Illegal Request [current] 
05:17:51,260 INFO kernel:[   82.888793] sd 2:0:0:0: [sda] Add. Sense: Invalid field in cdb
05:17:51,260 INFO kernel:[   82.888823] sd 2:0:0:0: [sda] CDB: Write(10) 2a 00 00 00 08 00 00 03 f0 00
05:17:51,260 ERR kernel:[   82.888834] blk_update_request: critical target error, dev sda, sector 2048
05:17:51,260 ERR kernel:[   82.888844] Buffer I/O error on device sda, logical block 256
05:17:51,260 WARNING kernel:[   82.888852] lost page write due to I/O error on sda
05:17:51,260 ERR kernel:[   82.888866] Buffer I/O error on device sda, logical block 257
05:17:51,260 WARNING kernel:[   82.888874] lost page write due to I/O error on sda
05:17:51,260 ERR kernel:[   82.888884] Buffer I/O error on device sda, logical block 258
05:17:51,260 WARNING kernel:[   82.888892] lost page write due to I/O error on sda
05:17:51,260 ERR kernel:[   82.888902] Buffer I/O error on device sda, logical block 259
05:17:51,260 WARNING kernel:[   82.888910] lost page write due to I/O error on sda
05:17:51,260 ERR kernel:[   82.888919] Buffer I/O error on device sda, logical block 260
05:17:51,260 WARNING kernel:[   82.888927] lost page write due to I/O error on sda
05:17:51,260 ERR kernel:[   82.888936] Buffer I/O error on device sda, logical block 261
05:17:51,260 WARNING kernel:[   82.888945] lost page write due to I/O error on sda
05:17:51,268 INFO kernel:[   82.896790]  sda:
05:17:51,490 INFO kernel:[   83.117050]  sda: sda1
05:17:52,061 INFO kernel:[   83.687544]  sda: sda1
05:17:52,293 INFO kernel:[   83.921550] sd 2:0:0:0: [sda] FAILED Result: hostbyte=DID_OK driverbyte=DRIVER
_SENSE
05:17:52,293 INFO kernel:[   83.921580] sd 2:0:0:0: [sda] Sense Key : Illegal Request [current] 
05:17:52,293 INFO kernel:[   83.921594] sd 2:0:0:0: [sda] Add. Sense: Invalid field in cdb
05:17:52,293 INFO kernel:[   83.921606] sd 2:0:0:0: [sda] CDB: Write(10) 2a 00 00 07 d8 20 00 02 00 00
05:17:52,293 ERR kernel:[   83.921615] blk_update_request: critical target error, dev sda, sector 514080


Looks like there are some issues with the disk.

Comment 7 Sandro Bonazzola 2018-10-10 15:29:26 UTC
(In reply to Samantha N. Bueno from comment #6)
> Looks like there are some issues with the disk.

So should this bug be closed as not a bug?

Comment 8 Sandro Bonazzola 2018-10-10 15:30:26 UTC
dguo are you able to reproduce with different disk?

Comment 9 cshao 2018-10-11 05:06:56 UTC
I will try to reproduce this issue with different disk, if can't reproduce it, I will close it.

Comment 10 cshao 2018-10-11 08:05:56 UTC
Close this bug as OS can be successfully installed on direct lun disk now.

Test version:
redhat-virtualization-host-4.2-20181003.1.el7_6


Note You need to log in before you can comment on or make changes to this bug.