Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1497084 - glusterfs process consume huge memory on both server and client node
Summary: glusterfs process consume huge memory on both server and client node
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: 3.12
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: hari gowtham
QA Contact:
URL:
Whiteboard:
Depends On: 1496379
Blocks: 1490203 1497108
TreeView+ depends on / blocked
 
Reported: 2017-09-29 07:28 UTC by hari gowtham
Modified: 2017-10-13 12:47 UTC (History)
15 users (show)

Fixed In Version: glusterfs-glusterfs-3.12.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1496379
: 1497108 (view as bug list)
Environment:
Last Closed: 2017-10-13 12:47:15 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-09-29 08:00:37 UTC
REVIEW: https://review.gluster.org/18410 (Posix: fix additional inode ref) posted (#1) for review on release-3.12 by hari gowtham (hari.gowtham005@gmail.com)

Comment 2 Worker Ant 2017-10-06 06:33:17 UTC
COMMIT: https://review.gluster.org/18410 committed in release-3.12 by jiffin tony Thottan (jthottan@redhat.com) 
------
commit d167bb0871f9fc8b150f026bb0a0710bd203c947
Author: hari gowtham <hgowtham@redhat.com>
Date:   Thu Sep 28 15:43:30 2017 +0530

    Posix: fix additional inode ref
    
            backport of https://review.gluster.org/#/c/18406/
    
    Problem: In the iteration, the inode is being ref-ed twice and
    unref-ed once. this leads to ref leak.
    
    Fix: assign the parent to the inode instead of referencing it.
    
    >BUG: 1496379
    
    Change-Id: Ib154b12d38ad68220f8f5288bbc50081beccc2b9
    BUG: 1497084
    Signed-off-by: hari gowtham <hgowtham@redhat.com>

Comment 3 Jiffin 2017-10-13 12:47:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.12.2, please open a new bug report.

glusterfs-glusterfs-3.12.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-October/032684.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.