Bug 149715 - local variable used before set
local variable used before set
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Gtk-Perl (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-25 13:03 EST by David Binderman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 15:42:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-02-25 13:03:11 EST
Description of problem:

I just tried to compile package Gtk-Perl-0.7008-37 from 
Redhat Fedora Extras development tree.

The compiler said

1.

GtkObject.xs(860): remark #592: variable "signals" is used before its
value is set

The source code is

               sv_setiv(s, signals);

but signals hasn't been set since it's declaration. 

                int signals;

Suggest init signals before first use.





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Saou 2005-04-07 15:42:30 EDT
Gtk-Perl is (AFAIK) unmaintained, and only provided as a legacy binding. If you
can provide a patch, I'll gladly included, but otherwise I really don't think
it's worth bothering unless this is known to cause serious issues.
Comment 2 David Binderman 2005-04-08 04:08:34 EDT
>If you can provide a patch

Suggest 

   int signals = 0;

This is untested.

Note You need to log in before you can comment on or make changes to this bug.