Bug 1497162 - smbcacls fails if no password is specified
Summary: smbcacls fails if no password is specified
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.4
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Andrej Dzilský
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-29 10:57 UTC by Marc Muehlfeld
Modified: 2018-04-10 17:31 UTC (History)
6 users (show)

Fixed In Version: samba-4.7.0-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 17:30:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0937 None None None 2018-04-10 17:31:04 UTC
Samba Project 12765 None None None 2019-01-03 02:49:41 UTC

Description Marc Muehlfeld 2017-09-29 10:57:28 UTC
Problem description:
If you run an smbcacls command without specifying the password in the -U parameter, the command fails and prints:
> cli_full_connection failed! (NT_STATUS_LOGON_FAILURE)
instead of asking for the password such as other tool do (e. g. "net" or "samba-tool").



Version-Release number of selected component (if applicable):
samba-client-4.6.2-11.el7_4.x86_64



Steps to reproduce:
1. Run:
   # smbcacls //server/share / -Uadministrator
   cli_full_connection failed! (NT_STATUS_LOGON_FAILURE)



Further details:
* The command works if you add the password to the -U parameter. For example:
  # smbcacls //server/share / -Uadministrator%password
  But this should not be the recommended way.
* Connections also work if you have a valid Kerberos ticket and pass the
  -k option to the command



Additional info:
This bug has been fixed upstream:
https://bugzilla.samba.org/show_bug.cgi?id=12765

Comment 3 Andrej Dzilský 2017-10-27 17:02:26 UTC
Verified. Smbcacls now prompts user for password if no password was used.

Comment 9 errata-xmlrpc 2018-04-10 17:30:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0937


Note You need to log in before you can comment on or make changes to this bug.