Bug 1497199 - cephmetrics-ansible ceph-grafana PyYAML
Summary: cephmetrics-ansible ceph-grafana PyYAML
Keywords:
Status: CLOSED DUPLICATE of bug 1497198
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Metrics
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 3.0
Assignee: ceph-eng-bugs
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-29 12:59 UTC by Lubos Trilety
Modified: 2017-10-04 13:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-04 13:34:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lubos Trilety 2017-09-29 12:59:28 UTC
Description of problem:
cephmetrics-ansible playbook.yml needs package pyYAML to be installed for task 'TASK [ceph-grafana : Push dashboards to Grafana]', however the playbook never checks if it is so and install the package if required.


Version-Release number of selected component (if applicable):
cephmetrics-ansible-1.0-1.el7cp.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Don't install PyYAML on ceph-grafana machine, if it's already installed remove it from the machine
2. Run cepmetrics-ansible playbook playbook.yml
3.

Actual results:
The playbook fails on task 'TASK [ceph-grafana : Push dashboards to Grafana]' with following error:
"ImportError: No module named yaml"


Expected results:
Playbook installs PyYAML on the machine before the task 'TASK [ceph-grafana : Push dashboards to Grafana]' is run.

Additional info:

Comment 1 Lubos Trilety 2017-10-04 13:34:16 UTC

*** This bug has been marked as a duplicate of bug 1497198 ***


Note You need to log in before you can comment on or make changes to this bug.