Bug 1497272 - [modularity] UX: Replace the "Group '...' does not exist." message
Summary: [modularity] UX: Replace the "Group '...' does not exist." message
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1497281 (view as bug list)
Depends On:
Blocks: 1478068
TreeView+ depends on / blocked
 
Reported: 2017-09-29 15:47 UTC by Daniel Mach
Modified: 2018-06-28 08:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-13 08:00:10 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Mach 2017-09-29 15:47:56 UTC
$ dnf install @httpd
Loading repositories.
Last metadata expiration check: 2:43:05 ago on Fri 29 Sep 2017 12:54:30 PM UTC.
Warning: Group 'httpd' does not exist.
Error: Nothing to do.

The message is misleading and needs to be replaced.



For example:
$ dnf install @foo
-> Module or group 'foo' doesn't exist.


$ dnf install @httpd
-> Module 'httpd' has no default stream. Please specify a stream.

$ dnf install @httpd:2.6
-> Module 'httpd', stream '2.6' doesn't exist.

etc.

Comment 1 Martin Hatina 2017-10-04 11:05:11 UTC
*** Bug 1497281 has been marked as a duplicate of this bug. ***

Comment 2 Martin Hatina 2017-10-04 11:36:52 UTC
Fixed by https://github.com/rpm-software-management/dnf/pull/942

Comment 3 Jaroslav Mracek 2018-06-28 08:07:34 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.