Bug 1497351 - [RFE] yum versionlock should give a note, if packages are blocked by update
Summary: [RFE] yum versionlock should give a note, if packages are blocked by update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum-utils
Version: 7.4
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Michal Domonkos
QA Contact: Eva Mrakova
Marie Dolezelova
URL:
Whiteboard:
Depends On:
Blocks: 1549618
TreeView+ depends on / blocked
 
Reported: 2017-09-29 21:15 UTC by Steffen Froemer
Modified: 2018-10-30 11:41 UTC (History)
6 users (show)

Fixed In Version: yum-utils-1.1.31-50.el7
Doc Type: Release Note
Doc Text:
The "yum versionlock" plug-in now displays which packages are blocked when running the "yum update" command Previously, the "yum versionlock" plug-in, which is used to lock RPM packages, did not display any information about packages excluded from the update. Consequently, users were not warned that such packages will not be updated when running the "yum update" command. With this update, "yum versionlock" has been changed. The plug-in now prints a message about how many package updates are being excluded. In addition, the new "status" subcommand has been added to the plug-in. The "yum versionlock status" command prints the list of available package updates blocked by the plug-in.
Clone Of:
Environment:
Last Closed: 2018-10-30 11:40:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3280 None None None 2018-10-30 11:41:13 UTC
Red Hat Bugzilla 578287 None CLOSED RFE: display excluded packages at top of transaction or after error messages 2019-08-30 02:42:19 UTC

Internal Links: 578287

Description Steffen Froemer 2017-09-29 21:15:51 UTC
Description of problem:
If packages are locked by using yum versionlock, one could forget about it and wondering, why packages not updated as expected.
calling `yum update` does not give any hint, that packages are locked by versionlock

Version-Release number of selected component (if applicable):
yum-plugin-versionlock-1.1.31-40.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Install RHEL 7.4
2. lock some packages
3. run `yum update`

Actual results:
# yum update does not mention any about locked packages

Expected results:
# yum update
Note: There are packages locked by yum-versionlock-plugin. For more info use `yum versionlock list

Additional Infos:
Example:


# yum update
Loaded plugins: product-id, search-disabled-repos, subscription-manager, versionlock
[...]
==============================================================================================
 Package                Arch        Version                    Repository                Size
==============================================================================================
Installing:
 kernel                 x86_64      3.10.0-693.2.2.el7         rhel-7-server-rpms        43 M
 kernel-devel           x86_64      3.10.0-693.2.2.el7         rhel-7-server-rpms        14 M
Updating:
 augeas-libs            x86_64      1.4.0-2.el7_4.1            rhel-7-server-rpms       355 k
 emacs-filesystem       noarch      1:24.3-20.el7_4            rhel-7-server-rpms        58 k
 kernel-headers         x86_64      3.10.0-693.2.2.el7         rhel-7-server-rpms       6.0 M
 kernel-tools           x86_64      3.10.0-693.2.2.el7         rhel-7-server-rpms       5.1 M
 kernel-tools-libs      x86_64      3.10.0-693.2.2.el7         rhel-7-server-rpms       5.0 M
 nss                    x86_64      3.28.4-12.el7_4            rhel-7-server-rpms       848 k
 nss-sysinit            x86_64      3.28.4-12.el7_4            rhel-7-server-rpms        60 k
 nss-tools              x86_64      3.28.4-12.el7_4            rhel-7-server-rpms       500 k
 python-perf            x86_64      3.10.0-693.2.2.el7         rhel-7-server-rpms       5.1 M
Removing:
 kernel                 x86_64      3.10.0-514.el7             @anaconda/7.3            148 M
 kernel-devel           x86_64      3.10.0-514.26.2.el7        @rhel-7-server-rpms       34 M

Transaction Summary
==============================================================================================
Install  2 Packages
Upgrade  9 Packages
Remove   2 Packages


# yum versionlock add kernel*
Loaded plugins: product-id, search-disabled-repos, subscription-manager, versionlock
Adding versionlock on: 0:kernel-devel-3.10.0-693.2.1.el7
Adding versionlock on: 0:kernel-tools-3.10.0-693.2.1.el7
Adding versionlock on: 0:kernel-3.10.0-693.1.1.el7
Adding versionlock on: 0:kernel-tools-libs-3.10.0-693.2.1.el7
Adding versionlock on: 0:kernel-3.10.0-514.el7
Adding versionlock on: 0:kernel-devel-3.10.0-514.26.2.el7
Adding versionlock on: 0:kernel-3.10.0-693.2.1.el7
Adding versionlock on: 0:kernel-headers-3.10.0-693.2.1.el7
Adding versionlock on: 0:kernel-devel-3.10.0-693.1.1.el7
versionlock added: 9


# yum update
Loaded plugins: product-id, search-disabled-repos, subscription-manager, versionlock
Resolving Dependencies
--> Running transaction check
---> Package augeas-libs.x86_64 0:1.4.0-2.el7 will be updated
---> Package augeas-libs.x86_64 0:1.4.0-2.el7_4.1 will be an update
---> Package emacs-filesystem.noarch 1:24.3-19.el7_3 will be updated
---> Package emacs-filesystem.noarch 1:24.3-20.el7_4 will be an update
---> Package nss.x86_64 0:3.28.4-11.el7_4 will be updated
---> Package nss.x86_64 0:3.28.4-12.el7_4 will be an update
---> Package nss-sysinit.x86_64 0:3.28.4-11.el7_4 will be updated
---> Package nss-sysinit.x86_64 0:3.28.4-12.el7_4 will be an update
---> Package nss-tools.x86_64 0:3.28.4-11.el7_4 will be updated
---> Package nss-tools.x86_64 0:3.28.4-12.el7_4 will be an update
---> Package python-perf.x86_64 0:3.10.0-693.2.1.el7 will be updated
---> Package python-perf.x86_64 0:3.10.0-693.2.2.el7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================
 Package                Arch         Version                   Repository                Size
==============================================================================================
Updating:
 augeas-libs            x86_64       1.4.0-2.el7_4.1           rhel-7-server-rpms       355 k
 emacs-filesystem       noarch       1:24.3-20.el7_4           rhel-7-server-rpms        58 k
 nss                    x86_64       3.28.4-12.el7_4           rhel-7-server-rpms       848 k
 nss-sysinit            x86_64       3.28.4-12.el7_4           rhel-7-server-rpms        60 k
 nss-tools              x86_64       3.28.4-12.el7_4           rhel-7-server-rpms       500 k
 python-perf            x86_64       3.10.0-693.2.2.el7        rhel-7-server-rpms       5.1 M

Transaction Summary
==============================================================================================
Upgrade  6 Packages

Comment 20 errata-xmlrpc 2018-10-30 11:40:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3280


Note You need to log in before you can comment on or make changes to this bug.