Bug 1497504 - anki: Can't download any plugins from Anki repository
Summary: anki: Can't download any plugins from Anki repository
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anki
Version: 26
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Drake-Brockman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-01 06:28 UTC by Eshin Kunishima
Modified: 2018-04-26 02:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 02:53:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Eshin Kunishima 2017-10-01 06:28:49 UTC
Description of problem:
Anki can't install any plugins due to SSL error.

Version-Release number of selected component (if applicable):

    Anki
    Version 2.0.43
    Qt 4.8.7 PyQt 4.12

    Name         : anki
    Version      : 2.0.43
    Release      : 1.fc26
    Arch         : noarch
    Size         : 11 M
    Source       : anki-2.0.43-1.fc26.src.rpm
    Repo         : @System
    From repo    : fedora


How reproducible:
1. Run anki
2. Open Tools -> Add-ons -> Browse & Install
3. Type code 1496166067 (ex https://ankiweb.net/shared/info/1496166067)
4. Click OK

Actual results:
* Show error dialog that includes a traceback.

Expected results:
* Anki downloads a plugin.
* Anki required to restart.

Additional info:

    Download failed: Traceback (most recent call last):
      File "/usr/share/anki/aqt/downloader.py", line 67, in run
        aqt.appShared + "download/%d" % self.code)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1671, in request
        (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1464, in _request
        redirections=redirections - 1)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1671, in request
        (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1411, in _request
        (response, content) = self._conn_request(conn, request_uri, method, body, headers)
      File "/usr/share/anki/aqt/sync.py", line 467, in _conn_request
        conn.connect()
      File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1104, in connect
        raise SSLHandshakeError(e)
    SSLHandshakeError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)

Comment 1 thunderingexile 2017-10-02 14:05:15 UTC
I have just had the same problem. An easy workaround for me was to download and install the latest version, 2.0.47, from Anki's website.

Comment 2 anton 2017-10-19 21:28:21 UTC
I have the same problem too!  every add-on cause it.

Comment 3 Thomas Drake-Brockman 2018-02-05 23:56:17 UTC
I can also reproduce this error with anki-2.0.43-2.fc27.

Comment 4 Fedora Update System 2018-04-12 17:12:48 UTC
anki-2.0.50-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-50039f6b61

Comment 5 Fedora Update System 2018-04-12 17:14:19 UTC
anki-2.0.50-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-70fac3f07e

Comment 6 Fedora Update System 2018-04-12 17:15:20 UTC
anki-2.0.50-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-58b0c6a60e

Comment 7 Fedora Update System 2018-04-15 02:22:20 UTC
anki-2.0.50-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-50039f6b61

Comment 8 Fedora Update System 2018-04-15 16:19:48 UTC
anki-2.0.50-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-70fac3f07e

Comment 9 Fedora Update System 2018-04-15 21:42:02 UTC
anki-2.0.50-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-58b0c6a60e

Comment 10 Fedora Update System 2018-04-17 00:18:29 UTC
anki-2.0.50-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-04-25 17:59:01 UTC
anki-2.0.50-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2018-04-25 18:16:00 UTC
anki-2.0.50-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.