Bug 1497677 - Blivet trys to import non-existent pyanaconda module
Summary: Blivet trys to import non-existent pyanaconda module
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1497796 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-02 12:35 UTC by Chad
Modified: 2017-10-04 22:26 UTC (History)
11 users (show)

Fixed In Version: python-blivet-2.1.11-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-04 22:26:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Chad 2017-10-02 12:35:38 UTC
Description of problem:
Anaconda installer breaks using the latest python3-blivet package

Version-Release number of selected component (if applicable):
python3-blivet-2.1.11-1.fc26.noarch

anaconda-core-26.21.12-1.fc26.x86_64

How reproducible:
$ python3
Python 3.6.2 (default, Sep 22 2017, 08:28:09) 
[GCC 7.2.1 20170915 (Red Hat 7.2.1-2)] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import blivet
>>> blivet.enable_installer_mode()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3.6/site-packages/blivet/__init__.py", line 127, in enable_installer_mode
    from pyanaconda.anaconda_logging import program_log_lock
ModuleNotFoundError: No module named 'pyanaconda.anaconda_logging'


Additional info:
It seems as though blivet was updated to use a newer version of anaconda.  The current version, 26.21.12 has an anaconda_log.py module.  There is no anaconda_logging module.

Comment 1 Vratislav Podzimek 2017-10-02 13:20:34 UTC
Vojta, maybe we need a downstream patch reverting the following change?

- Adapt to logging module name change (mkolman)

We are probably not going to get a new release of the anaconda package(s).

Comment 2 Vratislav Podzimek 2017-10-02 13:21:25 UTC
(In reply to Chad from comment #0)
> Description of problem:
> Anaconda installer breaks using the latest python3-blivet package
> 
> Version-Release number of selected component (if applicable):
> python3-blivet-2.1.11-1.fc26.noarch
> 
> anaconda-core-26.21.12-1.fc26.x86_64
> 
> How reproducible:
> $ python3
> Python 3.6.2 (default, Sep 22 2017, 08:28:09) 
> [GCC 7.2.1 20170915 (Red Hat 7.2.1-2)] on linux
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import blivet
> >>> blivet.enable_installer_mode()

Just out of curiosity, why do you need to enable the installer mode, Chad?

Comment 3 Chad 2017-10-02 13:25:24 UTC
I created a boot ISO via lorax.  It pulls in the latest packages when creating the ISO image.  I discovered when trying to use the boot ISO created by lorax.  I verified the issue using command-line python.

Comment 4 Fedora Update System 2017-10-03 07:36:22 UTC
python-blivet-2.1.11-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1fe6841db8

Comment 5 Jiri Konecny 2017-10-03 07:46:47 UTC
*** Bug 1497796 has been marked as a duplicate of this bug. ***

Comment 6 Chad 2017-10-03 15:16:42 UTC
The updated package resolves the issue.  Created a boot ISO using lorax with the updated python-blivet package installed.  The anaconda installer on the newly created boot ISO works as expected.

Comment 7 Fedora Update System 2017-10-04 22:26:25 UTC
python-blivet-2.1.11-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.