Bug 149773 - kernel*-devel should own /lib/modules/<version>
kernel*-devel should own /lib/modules/<version>
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-26 03:01 EST by Alexandre Oliva
Modified: 2015-01-04 17:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:48:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-02-26 03:01:26 EST
I found dozens of directories named 2.6.10-1.*_FC4smp in /lib/modules,
even though I've never had any smp kernel installed on my
rawhide-tracking box.  That's because kernel-smp-devel caused the dir
to be created because it owns the build and source subdirs, but since
it doesn't own the parent dir, it never gets removed after an upgrade.
Comment 1 Dave Jones 2005-09-28 04:48:46 EDT
but the -devel rpm's *don't* own that dir. (The fact that it got created when it
got installed is irrelevant here, typically, the parent is owned by the
kernel-smp package itself).

the problem here is why did that smp-devel package get installed in the first
place when you had no smp kernel installed. I believe Jeremy fixed a bug in
Anaconda a while ago that may have caused this.
Comment 2 Alexandre Oliva 2005-10-01 16:00:41 EDT
No, the problem of having smp-devel packages installed was a separate bug.  This
one was about the fact that -devel installed files in a directory it didn't own,
without a dep on the package that owned it, such than, in the absence of the dir
owner, when the package was removed, the directory would be left behind.

This has since been fixed by having the sources and build links in
/lib/modules/`uname -r`/ moved to the kernel dirs, exchanging the need for dir
(co-)owning for ugly dangling links when devel is not present.  Yuck.

Note You need to log in before you can comment on or make changes to this bug.