Bug 1497861 - Kernel module peaq_wmi nul bombing the console
Summary: Kernel module peaq_wmi nul bombing the console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1499382 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-02 22:18 UTC by Bojan Smojver
Modified: 2017-10-12 15:18 UTC (History)
23 users (show)

Fixed In Version: kernel-4.13.5-300.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-12 15:18:20 UTC


Attachments (Terms of Use)
ACPI dump (123.83 KB, text/plain)
2017-10-03 11:01 UTC, Bojan Smojver
no flags Details
DMI dump (9.02 KB, text/plain)
2017-10-03 11:02 UTC, Bojan Smojver
no flags Details
[PATCH] platform/x86: peaq-wmi: Add DMI check before binding to the WMI interface (2.04 KB, patch)
2017-10-05 14:19 UTC, Hans de Goede
no flags Details | Diff

Description Bojan Smojver 2017-10-02 22:18:25 UTC
Description of problem:
When this module (peaq_wmi) is loaded, it sends a continuous stream of nul characters to the console (displayed as ^@), every second or so.

Version-Release number of selected component (if applicable):
kernel-4.13.4-200.fc26.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Let the module get loaded by kernel on relevant hardware.

Actual results:
Nul bombed console.

Expected results:
Quiet console.

Additional info:
Blacklisting the module avoids the problem.

Comment 1 Laura Abbott 2017-10-02 22:29:06 UTC
I think this driver is new for 4.13. Hans, any idea what might be going on here?

Comment 2 Hans de Goede 2017-10-03 08:05:16 UTC
Hi,

(In reply to Laura Abbott from comment #1)
> I think this driver is new for 4.13. Hans, any idea what might be going on
> here?

I've received a similar bug report by email, it seems that the WMI UUID the driver is binding to is used on (some) other devices to and the WMI interface behaves differently there.

Bojan, what hardware are you seeing this on ?

Also I'm going to need some info from your machine to debug this, can you run:

sudo dnf install acpica-tools
sudo acpidump -o machinename.acpidump

And then attach the generated machinename.acpidump file here, as well as run:

sudo dnf install dmidecode
sudo dmidecode > machinename.dmi

And then attach the generated machinename.dmi file here?

Thanks & Regards,

Hans

Comment 3 Bojan Smojver 2017-10-03 11:01:55 UTC
Created attachment 1333595 [details]
ACPI dump

Comment 4 Bojan Smojver 2017-10-03 11:02:26 UTC
Created attachment 1333596 [details]
DMI dump

Comment 5 Hans de Goede 2017-10-05 14:19:30 UTC
Created attachment 1334860 [details]
[PATCH] platform/x86: peaq-wmi: Add DMI check before binding to the WMI interface

Thank you for the info.

I'm attaching a patch which fixes this. I'm also submitting this patch to the upstream kernel (with a Cc: stable).

Laura can you add this patch to the Fedora kernels to fix this for now ?

Comment 6 Fedora Update System 2017-10-06 00:25:16 UTC
kernel-4.13.5-300.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1ebec0d18d

Comment 7 Fedora Update System 2017-10-06 00:26:51 UTC
kernel-4.13.5-200.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-81c8b510a2

Comment 8 Fedora Update System 2017-10-06 19:52:51 UTC
kernel-4.13.5-200.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-81c8b510a2

Comment 9 Fedora Update System 2017-10-06 22:25:41 UTC
kernel-4.13.5-300.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1ebec0d18d

Comment 10 Fedora Update System 2017-10-10 21:22:35 UTC
kernel-4.13.5-200.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Serge Matveenko 2017-10-11 07:02:54 UTC
*** Bug 1499382 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2017-10-12 15:18:20 UTC
kernel-4.13.5-300.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.