Bug 14979 - Don't include perl modules (MD5) with core perl package
Summary: Don't include perl modules (MD5) with core perl package
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-01 15:45 UTC by Chris Adams
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 16:16:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Adams 2000-08-01 15:45:50 UTC
Please don't include any modules from CPAN in the core perl package.  When
you do, it is impossible to upgrade to a newer version of that module
without rebuilding the entire perl distribution.

This is a problem especially because the MD5 module is included with perl,
but that module is obsolete (Digest-MD5 should be used now instead).

Comment 1 Nalin Dahyabhai 2000-08-07 12:10:19 UTC
The MD5 module is required by the cleanfeed package, so the module has to be in
the distribution somewhere.  MD5 is replace by Digest::MD5 in the latest build
because it provides a backwards-compatible interface.

Comment 2 Chris Adams 2000-08-07 16:16:37 UTC
I still say that no perl modules should be included in the core
perl package just because one program requires a module.  That
goes against the whole package scheme: you don't include gtk+
in glib just because something that requires glib requires
gtk+.  If a bug is found in Digest::MD5, or a new version with
more features is released, it is impossible to install it
without replacing the whole perl install (or by using --force
to override conflicts, which is ugly).
Perl modules should be made as separate packages.  If the
Digest::MD5 module is needed, then make a Digest-MD5 (or
better, perl-Digest-MD5) RPM for that module.

Comment 3 Nalin Dahyabhai 2000-08-07 16:23:24 UTC
I agree, but at this point it's far too late to get the description and summary
for a new package translated in time for the upcoming release.


Note You need to log in before you can comment on or make changes to this bug.