Bug 1497933 - [TestOnly] Verify (QE) an alternative method of configuring sysprep that does not require restart
Summary: [TestOnly] Verify (QE) an alternative method of configuring sysprep that does...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.3
: ---
Assignee: Michal Skrivanek
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks: 1269970 1490107
TreeView+ depends on / blocked
 
Reported: 2017-10-03 07:24 UTC by Lucy Bopf
Modified: 2019-05-16 13:07 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1490107
Environment:
Last Closed: 2018-05-15 17:45:15 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)
windows 2012 - error loading sysprep file (317.54 KB, image/png)
2017-10-19 13:06 UTC, Israel Pinto
no flags Details
setupact log (27.83 KB, text/plain)
2017-10-25 12:01 UTC, Israel Pinto
no flags Details
setup_logs (5.22 KB, application/x-xz)
2017-11-14 19:14 UTC, Israel Pinto
no flags Details
screenshot win7 (501.28 KB, image/png)
2017-11-14 19:15 UTC, Israel Pinto
no flags Details
VM is activated with same KEY (110.50 KB, image/png)
2018-03-26 14:51 UTC, Israel Pinto
no flags Details
setupact.log_26_3_2018 (41.73 KB, text/plain)
2018-03-26 14:53 UTC, Israel Pinto
no flags Details
vbs to check key (1.59 KB, text/plain)
2018-03-26 14:54 UTC, Israel Pinto
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:46:19 UTC

Description Lucy Bopf 2017-10-03 07:24:34 UTC
The procedure outlined in the 'Description of problem' below must be tested and verified before it can be included in the documentation.

This bug tracks the request for QE testing.


+++ This bug was initially created as a clone of Bug #1490107 +++

Description of problem:
In bug https://bugzilla.redhat.com/show_bug.cgi?id=1269970 Miguel Martin (comment 11) suggested an alternative method of configuring sysprep (i.e. not using the engine-config) by making a copy of the default sysprep.

This method has the advantage not needing to restart the engine.
This method has been approved by Yaniv Kaul but needs to be verified by QE before it can be added to the documentation.

1. Install a Windows Machine, seal it, and create a template from it, just as described in the KCS.
2. Create a pool based on the previous template with sysprep customization.

For this solution, we will specify the user/pass and the product key using a custom sysprep (in pool 'Initial Run' tab), that is, a copy of the default sysprep.
In case of a Windows 7 x64 os, the default sysprep is in file '/usr/share/ovirt-engine/conf/sysprep/sysprep.w7x64'.

So, once we pasted the content of the file in the 'sysprep' textbox (in the pool 'Inital Run' tab) we modify the following info:

......
                <ProductKey>
                    <Key><![CDATA[$ProductKey$]]></Key>  ----------------------> with <Key>xxxx-xxx-xxx-xxx</Key>
                </ProductKey>
.....
                <Credentials>
                    <Domain><![CDATA[$JoinDomain$]]></Domain>
                    <Password><![CDATA[$DomainAdminPassword$]]></Password>  ----------------------> with the domain password<Password>mypassword</Password>
                    <Username><![CDATA[$DomainAdmin$]]></Username> ----------------------> with the domain admin user<Username>DomainAdministrator</Username>
                </Credentials>
......

There is no need to modify rest of the variables in the xml as they can be filled from the 'Initial Run' tab fields (Domain, OU, Organization Name, Custom Locale..)
Well, maybe I would modify the local user admin named 'user',:

......
           <UserData>
            ..........
                <FullName>"user"</FullName> <----------------------------- with <FullName>"mylocaladmin"</FullName>
            ..........
            </UserData>
......
               <LocalAccounts>
                    <LocalAccount wcm:action="add">
                        <Password>
                            <Value><![CDATA[$AdminPassword$]]></Value>
                            <PlainText>true</PlainText>
                        </Password>
                        <DisplayName>user</DisplayName> <----------------------------- with <DisplayName>mylocaladmin</DisplayName>
                        <Group>administrators</Group>
                        <Name>user</Name> <----------------------------- with <Name>mylocaladmin</Name>
                    </LocalAccount>
                </LocalAccounts>
.........

--- Additional comment from Lucy Bopf on 2017-09-21 01:57:40 EDT ---

Given that this bug depends on the solution being QE tested first, we either need to change the component to the responsible engineering team, or raise a separate eng TEST ONLY bug to allow QE to schedule this.

Martin/Yaniv, can you help us identify the correct component against which to track this request?

--- Additional comment from Martin Perina on 2017-09-21 05:07:01 EDT ---

Forwarding question to Michal

--- Additional comment from Michal Skrivanek on 2017-09-21 07:50:08 EDT ---

IMO it doesn't need much verification, the suggested approach is a regular feature for couple releases already, so should be covered
The suggested procedure makes sense to me

Feel free to just make changes as part of the original bug and turn this one into virt TestOnly bug, or open new one, as you prefer

--- Additional comment from Lucy Bopf on 2017-10-03 03:14:45 EDT ---

Thanks, Michal. Our policy is that all published documentation must be based on tested procedures, as confirmed by us: we ask for an existing test case, or we raise a new request. Because it's a newly-suggested procedure (though a supported and tested feature), we'd like to proceed with testing.

The original bug is almost complete now, so I'll keep this one for the docs request, and open a new bug for testing.

Comment 1 Israel Pinto 2017-10-19 13:04:25 UTC
I check it with : 4.1.7.3-0.1.el7 
with windows 7 64Bit and windows 2012 R2 64Bit 
And did the following steps: 
1. Modify default admin/pass to join the domain with engine-config:
 engine-config -s "SysPrepDefaultPassword=interactive"
 engine-config -s "SysPrepDefaultUser=administrator"
2. Create a new file called '99-default.properties' and modify the productKey variable in '99-default.properties' for the corresponding windows version
3. Restart the engine.
4. Install a Windows Machine, seal it, and create a template from it.
5. Create a pool based on the previous template and set host name under Initial run.
6. Start VM with run once. 

Results:
Windows 2012: VM started with error, See screenshot attached for windows 2012. 
Window 7: VM started but as seal VM, sysprep setting did not configured on VM.

logs: https://drive.google.com/open?id=0BxBXxc5waimaWFNJUzBINlRUMEk

Comment 2 Israel Pinto 2017-10-19 13:06:12 UTC
Created attachment 1340758 [details]
windows 2012 - error loading sysprep file

Comment 3 Emma Heftman 2017-10-23 07:42:27 UTC
(In reply to Israel Pinto from comment #1)
> I check it with : 4.1.7.3-0.1.el7 
> with windows 7 64Bit and windows 2012 R2 64Bit 
> And did the following steps: 
> 1. Modify default admin/pass to join the domain with engine-config:
>  engine-config -s "SysPrepDefaultPassword=interactive"
>  engine-config -s "SysPrepDefaultUser=administrator"
> 2. Create a new file called '99-default.properties' and modify the
> productKey variable in '99-default.properties' for the corresponding windows
> version
> 3. Restart the engine.
> 4. Install a Windows Machine, seal it, and create a template from it.
> 5. Create a pool based on the previous template and set host name under
> Initial run.
> 6. Start VM with run once. 
> 
> Results:
> Windows 2012: VM started with error, See screenshot attached for windows
> 2012. 
> Window 7: VM started but as seal VM, sysprep setting did not configured on
> VM.
> 
> logs: https://drive.google.com/open?id=0BxBXxc5waimaWFNJUzBINlRUMEk

Hi Israel,

Actually the method that needed checking is the one in the description of this bug:https://bugzilla.redhat.com/show_bug.cgi?id=1497933#c0

Thanks
Emma

Comment 4 Israel Pinto 2017-10-24 11:20:53 UTC
please take a look at this BZ https://bugzilla.redhat.com/show_bug.cgi?id=1419562
We did this check in the BZ. Please update me if it's covered the case.

Comment 5 Israel Pinto 2017-10-25 12:01:47 UTC
Created attachment 1343180 [details]
setupact log

Comment 6 Israel Pinto 2017-10-25 12:07:37 UTC
Hi all,

I recheck the setting with unattend xml with: product key, username and password.
The VM is started in as seal VM. 
Also I try only with product key same results.

Attached  C:\Windows\Panther\UnattendGC\setupact.log

Comment 7 Miguel Martin 2017-10-25 14:15:41 UTC
The Windows 7 setup fails because it can't find the unattend file:

~~~
2017-03-20 11:09:18, Info  [windeploy.exe] Found no unattend file.
2017-03-20 11:09:24, Info  [windeploy.exe] Started WinSAT; will need to wait
2017-03-20 11:09:25, Info  [windeploy.exe] Launching [C:\Windows\system32\oobe\oobeldr.exe /system]...
~~~

Once the Win 7 OS is fully booted, can you see floppy device attached to Win7 vm, and a Unattend.xml file inside?


Regarding step 5 ("Create a pool based on the previous template and set host name under Initial run") you also need to set the domain you want to join to. 
It can be the reason why the windows 2012 setup fails, the domain user and pass are filled but not the domain.

Can you please attach the setupact.log file from the windows 2012 vm?

Comment 8 Israel Pinto 2017-10-29 14:55:54 UTC
(In reply to Miguel Martin from comment #7)
> The Windows 7 setup fails because it can't find the unattend file:
> 
> ~~~
> 2017-03-20 11:09:18, Info  [windeploy.exe] Found no unattend file.
> 2017-03-20 11:09:24, Info  [windeploy.exe] Started WinSAT; will need to wait
> 2017-03-20 11:09:25, Info  [windeploy.exe] Launching
> [C:\Windows\system32\oobe\oobeldr.exe /system]...
> ~~~
> 
> Once the Win 7 OS is fully booted, can you see floppy device attached to
> Win7 vm, and a Unattend.xml file inside?
> 
Yes we have Unattend.xml file inside in A:Unattend.xml 
which is the same as the sysprep file i attached
> 
> Regarding step 5 ("Create a pool based on the previous template and set host
> name under Initial run") you also need to set the domain you want to join
> to. 
> It can be the reason why the windows 2012 setup fails, the domain user and
> pass are filled but not the domain.
> 
> Can you please attach the setupact.log file from the windows 2012 vm?
VM failed to start, i can login to VM.

Comment 9 Miguel Martin 2017-11-08 13:14:48 UTC
Israel,

Can you please perform the following steps before sealing the Windows 7 virtual machine?: 

Press Windows+R to launch a Run dialog. Enter regedit and press Enter. Click OK to authorize running regedit with system permissions.

In the Registry Editor window, use the left tree to navigate to HKEY_LOCAL_MACHINE → SYSTEM → Setup. In the right pane, right-click and select New → String Value. Enter UnattendFile as the key name. Double-click the new key and set the value to A:\Unattend.xml

The Windows 7 version I tested was Ultimate not Enterprise, and the previous steps are not needed, not sure about Enterprise version.

According to the logs the problem is that it can find the Unattend file, but the file is there. So I can only suppose it is looking for a different Unattend filename.

Comment 10 Israel Pinto 2017-11-14 19:13:50 UTC
Hi all,

I try it again on 4.2 version:

Did the steps:
1. Set the UnattendFile key in the registry 
2. Seal VM
3. Create template
4. Create Pool and configure the sysprep XML with product key and set it in 
   custom script. Also set hostname, custom locale in the UI.
Results:
VM is running: 
1. All the setting from the UI configure on VM.
2. The product key did not set.

See attached screenshot and  C:\Windows\Panther\UnattendGC\setupact.log and setuperr.log

Comment 11 Israel Pinto 2017-11-14 19:14:27 UTC
Created attachment 1352109 [details]
setup_logs

Comment 12 Israel Pinto 2017-11-14 19:15:44 UTC
Created attachment 1352114 [details]
screenshot win7

Comment 13 Israel Pinto 2017-11-14 19:16:34 UTC
(In reply to Israel Pinto from comment #10)
> Hi all,
> 
> I try it again on 4.2 version: Software version:4.2.0-0.0.master.20171108151837.gita7de53e.el7.centos

> 
> Did the steps:
> 1. Set the UnattendFile key in the registry 
> 2. Seal VM
> 3. Create template
> 4. Create Pool and configure the sysprep XML with product key and set it in 
>    custom script. Also set hostname, custom locale in the UI.
> Results:
> VM is running: 
> 1. All the setting from the UI configure on VM.
> 2. The product key did not set.
> 
> See attached screenshot and  C:\Windows\Panther\UnattendGC\setupact.log and
> setuperr.log

Comment 14 Miguel Martin 2017-11-15 10:13:54 UTC
(In reply to Israel Pinto from comment #10)
> Hi all,
> 
> I try it again on 4.2 version:
> 
> Did the steps:
> 1. Set the UnattendFile key in the registry 
> 2. Seal VM
> 3. Create template
> 4. Create Pool and configure the sysprep XML with product key and set it in 
>    custom script. Also set hostname, custom locale in the UI.
> Results:
> VM is running: 
> 1. All the setting from the UI configure on VM.
> 2. The product key did not set.
> 
> See attached screenshot and  C:\Windows\Panther\UnattendGC\setupact.log and
> setuperr.log

Maybe I am wrong but according to the log the product key was installed successfully:
~~~
2017-11-14 17:20:20, Info                         [msoobe.exe] Successfully installed product key
~~~

were you asked to introduce the Windows product key in the first run of Windows 7 virtual machine, I mean before login for the first time on Windows?

And also, according to the log, there was no valid domain data in Unattend file. You didn't introduce a valid domain nor user/password to join with. "internal-authz" is not a valid Windows domain but the default value in "Run Once" dialog. You didn't fill "Alternative Credentials" with the user and password to join the domain, and you didn't set up the default user/pass with engine-config either (at least one of them is required) because if you had done "Username" would not be "[NULL]"

~~~
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: Begin
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: Loading input parameters...
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: AccountData = [NULL]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: UnsecureJoin = [NULL]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: MachinePassword = [secret not logged]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: JoinDomain = [internal-authz]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: JoinWorkgroup = [NULL]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: Domain = [internal-authz]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: Username = [NULL]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: Password = [secret not logged]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: MachineObjectOU = [NULL]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: DebugJoin = [NULL]
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: DebugJoinOnlyOnThisError = [NULL]
2017-11-14 17:17:12, Error                        [DJOIN.EXE] Unattended Join: Failed to load all required input parameters, error occured processing [Username]: 0x57
2017-11-14 17:17:12, Error                        [DJOIN.EXE] Unattended Join: Unable to join; gdwError = 0x57
2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended Join: Exit, returning 0x0
~~~

Comment 15 Israel Pinto 2017-11-15 11:21:47 UTC
(In reply to Miguel Martin from comment #14)
> (In reply to Israel Pinto from comment #10)
> > Hi all,
> > 
> > I try it again on 4.2 version:
> > 
> > Did the steps:
> > 1. Set the UnattendFile key in the registry 
> > 2. Seal VM
> > 3. Create template
> > 4. Create Pool and configure the sysprep XML with product key and set it in 
> >    custom script. Also set hostname, custom locale in the UI.
> > Results:
> > VM is running: 
> > 1. All the setting from the UI configure on VM.
> > 2. The product key did not set.
> > 
> > See attached screenshot and  C:\Windows\Panther\UnattendGC\setupact.log and
> > setuperr.log
> 
> Maybe I am wrong but according to the log the product key was installed
> successfully:
> ~~~
> 2017-11-14 17:20:20, Info                         [msoobe.exe] Successfully
> installed product key
> ~~~
> 
> were you asked to introduce the Windows product key in the first run of
> Windows 7 virtual machine, I mean before login for the first time on Windows?
> 
> And also, according to the log, there was no valid domain data in Unattend
> file. You didn't introduce a valid domain nor user/password to join with.
> "internal-authz" is not a valid Windows domain but the default value in "Run
> Once" dialog. You didn't fill "Alternative Credentials" with the user and
> password to join the domain, and you didn't set up the default user/pass
> with engine-config either (at least one of them is required) because if you
> had done "Username" would not be "[NULL]"
> 
> ~~~
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: Begin
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: Loading input parameters...
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: AccountData = [NULL]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: UnsecureJoin = [NULL]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: MachinePassword = [secret not logged]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: JoinDomain = [internal-authz]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: JoinWorkgroup = [NULL]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: Domain = [internal-authz]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: Username = [NULL]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: Password = [secret not logged]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: MachineObjectOU = [NULL]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: DebugJoin = [NULL]
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: DebugJoinOnlyOnThisError = [NULL]
> 2017-11-14 17:17:12, Error                        [DJOIN.EXE] Unattended
> Join: Failed to load all required input parameters, error occured processing
> [Username]: 0x57
> 2017-11-14 17:17:12, Error                        [DJOIN.EXE] Unattended
> Join: Unable to join; gdwError = 0x57
> 2017-11-14 17:17:12, Info                         [DJOIN.EXE] Unattended
> Join: Exit, returning 0x0
> ~~~


Can you see the screenshot of the system, the key there is not the key i set in the XML.

Comment 16 Miguel Martin 2017-11-21 10:47:22 UTC
Hi Israel,

Are you sure the key is valid?
Can you please paste the generated Unattend.xml file in a private comment?

Comment 22 Michal Skrivanek 2018-01-11 08:48:23 UTC
Miguel, so what are your thoughts? If we can't get it working we probably shouldn't make this change

Comment 23 Miguel Martin 2018-01-11 10:17:27 UTC
Hi Michal,

Everything works for me except the Windows Product Key Activation as I don't have any valid key. It looks like the QE keys I tried are not valid for the windows versions I have.

So the first thing is to make sure the product keys they have are valid. They can test them installing a Windows VM an trying to set their product keys.

If that works, the rest should work just in the same way as the already documented method because in the end, the documented way uses the XML from '/usr/share/ovirt-engine/conf/sysprep/' directory, and substitutes the variables in the sysprep XML with:
1. the values taken from the web UI, 
2. the variables from the engine config (defaut user and pass used to join the domain) 
3. the variables taken from the properties files (the product key). 

In this method we provide the same sysprep XML (copied from the same directory), replacing by hand the product key, and default user/pass to join the domain and for the rest of the variables we take the values from the web UI.

Comment 24 Yaniv Kaul 2018-03-18 09:04:31 UTC
Michal, what's the next step?

Comment 25 Michal Skrivanek 2018-03-21 19:10:10 UTC
(In reply to Miguel Martin from comment #23)
> In this method we provide the same sysprep XML (copied from the same
> directory), replacing by hand the product key, and default user/pass to join
> the domain and for the rest of the variables we take the values from the web
> UI.

I agree. We were just hoping to get QE confirmation that it works. 

Israel, we really need to find out whether you're using valid product keys or not, to find out whether the new method is any different from the old one.
Can you please try the _same_ values using the old method and new method and check if there is any difference?

Comment 26 Israel Pinto 2018-03-26 14:50:21 UTC
Verify with:
Software Version:4.2.2.5-0.1.el7

Steps:
1. Set the UnattendFile key in the registry 
2. Seal VM
3. Create template
4. Create VM and configure the sysprep XML with product key and set it in 
   custom script. 
Results:
I check the key after sysprep using attached script , and the key is origin windows key,I activate the VM manually with the same key and VM is activate,see screenshot

Failed QA - key on custom script not set on windows 7.

Comment 27 Israel Pinto 2018-03-26 14:51:05 UTC
Created attachment 1413198 [details]
VM is activated with same KEY

Comment 28 Israel Pinto 2018-03-26 14:53:26 UTC
Created attachment 1413199 [details]
setupact.log_26_3_2018

Comment 29 Israel Pinto 2018-03-26 14:54:34 UTC
Created attachment 1413200 [details]
vbs to check key

Comment 30 Tomáš Golembiovský 2018-04-10 14:15:08 UTC
Looking at the error it looks like your key is not usable anymore. From the error description: 

0xC004C020
	The activation server reported that the Multiple Activation Key has exceeded its limit.

Israel, I'd suggest you sync with pstehlik or jbelka to get a usable key for your installation.

Alternatively try using a generic volume license keys listed here: 
https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-R2-and-2012/jj612867(v=ws.11)

The key will not activate the installation, but works for the purposes of sysprep good enough.

Comment 31 Israel Pinto 2018-04-10 14:29:08 UTC
(In reply to Tomáš Golembiovský from comment #30)
> Looking at the error it looks like your key is not usable anymore. From the
> error description: 
> 
> 0xC004C020
> 	The activation server reported that the Multiple Activation Key has
> exceeded its limit.
> 
> Israel, I'd suggest you sync with pstehlik or jbelka to get a usable key for
> your installation.
> 
> Alternatively try using a generic volume license keys listed here: 
> https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-
> server-2012-R2-and-2012/jj612867(v=ws.11)
> 
> The key will not activate the installation, but works for the purposes of
> sysprep good enough.

This key is good as i said i manage to active it manually see screenshot attached.
So the Key is good and i am using the keys the pstehlik and jbelka
using.

Comment 32 Michal Skrivanek 2018-04-13 10:12:05 UTC
(In reply to Israel Pinto from comment #31)
> (In reply to Tomáš Golembiovský from comment #30)
> > Looking at the error it looks like your key is not usable anymore. From the
> > error description: 
> > 
> > 0xC004C020
> > 	The activation server reported that the Multiple Activation Key has
> > exceeded its limit.
> > 
> > Israel, I'd suggest you sync with pstehlik or jbelka to get a usable key for
> > your installation.
> > 
> > Alternatively try using a generic volume license keys listed here: 
> > https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-
> > server-2012-R2-and-2012/jj612867(v=ws.11)
> > 
> > The key will not activate the installation, but works for the purposes of
> > sysprep good enough.
> 
> This key is good as i said i manage to active it manually see screenshot
> attached.
> So the Key is good and i am using the keys the pstehlik and jbelka
> using.

Yet the activation server said the key is not good. I suggest to try a different key

Lucy, I suggest to move forward. The bug was verified except for the problematic activation part. I believe the simplified method is still valid regardless what the final conclusion is going to be

Comment 33 Yaniv Kaul 2018-04-24 11:01:27 UTC
This is not a blocker nor an exception, yet it is targeted for 4.2.3?

Comment 34 Michal Skrivanek 2018-04-25 12:47:25 UTC
(In reply to Yaniv Kaul from comment #33)
> This is not a blocker nor an exception, yet it is targeted for 4.2.3?

there's no action here other than QE verification which is stuck on activation key.

Comment 37 Israel Pinto 2018-05-03 04:56:56 UTC
I recheck it and i see in the log from the last test that the key is installed

2017-03-20 11:14:44, Info [msoobe.exe] Successfully installed product key

So RHEVM is setting the via unattend.xml and the problem is windows issue, Not the key or RHEVM.

I search the issue of setting the product key with sysperp using unattend.xml
There is problem with setting the key that can relate to the fact that there is no internal connection while setting the key.
see: https://social.technet.microsoft.com/Forums/ie/en-US/c4f0f9bc-5255-4ebb-8578-b478ec787400/product-key-not-working-in-unattend?forum=mdt
In this post they use different xml settings I test it and it failed with error:
Failed to install product key [hr=0xC004F050] 
So i can be really windows problem not sysprep, network issue.

Closing the BZ - Verfied

Comment 41 errata-xmlrpc 2018-05-15 17:45:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 42 Franta Kust 2019-05-16 13:07:50 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.