Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
For bugs related to Red Hat Enterprise Linux 4 product line. The current stable release is 4.9. For Red Hat Enterprise Linux 6 and above, please visit Red Hat JIRA https://issues.redhat.com/secure/CreateIssue!default.jspa?pid=12332745 to report new issues.

Bug 149796

Summary: anaconda failed during RHEL4 WS install on raid5 device
Product: Red Hat Enterprise Linux 4 Reporter: Clyde E. Kunkel <clydekunkel7734>
Component: anacondaAssignee: Peter Jones <pjones>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: atodorov, dkl, jlaska, mikem
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-04 07:28:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
anaconda traceback created by installer before reboot. none

Description Clyde E. Kunkel 2005-02-27 04:54:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
Anaconda failed with traceback during attempted install on newly
established raid5 array.  No packages installed.  Array had been a
raid0.  Deleted raid0 array in disk druid and created 3 disk raid5
array. /boot was on non-raid partion, / was to be on the raid5

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.The raid0 array was stopped under FC4.
2.An additional partition was marked fd with fdisk.
3.Rebooted to RHEL4 install CD
4.Manually partitioned using disk druid.
5.Deleted raid0 array.
6.Created raid5 array using formed raid0 devices and additional
partion (had previously been used for another distribution)
    

Actual Results:  Error message that anaconda failed, traceback
available, just before any packages were to be installed.  Packages
for installation had been selected.

Expected Results:  Normal, good RHEL install on raid5

Additional info:

After failure, rebooted to FC3+rawhide installation.  Stopped the
raid0 array and using mdadm created the raid5 array.  Rebooted to
RHEL4 insall CD and disk druid saw the raid5 array.  Installation of /
on the raid5 went smoothly.

Comment 1 Clyde E. Kunkel 2005-02-27 04:56:41 UTC
Created attachment 111459 [details]
anaconda traceback created by installer before reboot.

Comment 2 Jay Turner 2005-02-28 07:32:39 UTC
*** Bug 137449 has been marked as a duplicate of this bug. ***

Comment 4 Mike McLean 2005-03-30 21:42:34 UTC
*** Bug 152632 has been marked as a duplicate of this bug. ***

Comment 18 RHEL Program Management 2006-08-18 17:48:44 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 23 RHEL Program Management 2007-04-17 21:30:04 UTC
Although this bugzilla was approved for RHEL 4.5, we were unable
to resolve it in time to be included in the release.  Therefore
it is now proposed for RHEL 4.6.

Comment 24 RHEL Program Management 2007-05-09 11:28:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 25 Clyde E. Kunkel 2007-05-09 15:46:07 UTC
I cannot test this further since I no longer use RHEL, but instead use Fedora. 
HOWEVER, FC7T4 and net installs of rawhide do not correctly detect pre-existing
software raid arrays.  See 237456.  Issue was also reported with FC6 during
testing, but was closed by developer as not reproducible.  Have now seen this on
two machines.

Comment 26 Suzanne Logcher 2007-09-17 19:57:26 UTC
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Comment 27 Denise Dumas 2008-04-17 13:41:23 UTC
Once again we ran out of time for this one. 

Comment 28 Alexander Todorov 2008-05-05 11:13:09 UTC
isn't that a dupe of bug #172648?

we've see the error message "ValueError: md0 is already in the mdList!" for
quite a few bugzillas and they should be resolved now. 

I'll mark this as duplicate if there's no response in reasonable amount of time.

Thanks.

Comment 32 Alexander Todorov 2008-06-04 07:28:32 UTC
Closing this bug as duplicate of bug #172648.

If you still have this issue please re-open.

*** This bug has been marked as a duplicate of 172648 ***