Bug 149796 - anaconda failed during RHEL4 WS install on raid5 device
anaconda failed during RHEL4 WS install on raid5 device
Status: CLOSED DUPLICATE of bug 172648
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
: 137449 152632 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-26 23:54 EST by Clyde E. Kunkel
Modified: 2008-06-04 03:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 03:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda traceback created by installer before reboot. (749.79 KB, text/plain)
2005-02-26 23:56 EST, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2005-02-26 23:54:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
Anaconda failed with traceback during attempted install on newly
established raid5 array.  No packages installed.  Array had been a
raid0.  Deleted raid0 array in disk druid and created 3 disk raid5
array. /boot was on non-raid partion, / was to be on the raid5

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.The raid0 array was stopped under FC4.
2.An additional partition was marked fd with fdisk.
3.Rebooted to RHEL4 install CD
4.Manually partitioned using disk druid.
5.Deleted raid0 array.
6.Created raid5 array using formed raid0 devices and additional
partion (had previously been used for another distribution)
    

Actual Results:  Error message that anaconda failed, traceback
available, just before any packages were to be installed.  Packages
for installation had been selected.

Expected Results:  Normal, good RHEL install on raid5

Additional info:

After failure, rebooted to FC3+rawhide installation.  Stopped the
raid0 array and using mdadm created the raid5 array.  Rebooted to
RHEL4 insall CD and disk druid saw the raid5 array.  Installation of /
on the raid5 went smoothly.
Comment 1 Clyde E. Kunkel 2005-02-26 23:56:41 EST
Created attachment 111459 [details]
anaconda traceback created by installer before reboot.
Comment 2 Jay Turner 2005-02-28 02:32:39 EST
*** Bug 137449 has been marked as a duplicate of this bug. ***
Comment 4 Mike McLean 2005-03-30 16:42:34 EST
*** Bug 152632 has been marked as a duplicate of this bug. ***
Comment 18 RHEL Product and Program Management 2006-08-18 13:48:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 23 RHEL Product and Program Management 2007-04-17 17:30:04 EDT
Although this bugzilla was approved for RHEL 4.5, we were unable
to resolve it in time to be included in the release.  Therefore
it is now proposed for RHEL 4.6.
Comment 24 RHEL Product and Program Management 2007-05-09 07:28:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 25 Clyde E. Kunkel 2007-05-09 11:46:07 EDT
I cannot test this further since I no longer use RHEL, but instead use Fedora. 
HOWEVER, FC7T4 and net installs of rawhide do not correctly detect pre-existing
software raid arrays.  See 237456.  Issue was also reported with FC6 during
testing, but was closed by developer as not reproducible.  Have now seen this on
two machines.
Comment 26 Suzanne Yeghiayan 2007-09-17 15:57:26 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 27 Denise Dumas 2008-04-17 09:41:23 EDT
Once again we ran out of time for this one. 
Comment 28 Alexander Todorov 2008-05-05 07:13:09 EDT
isn't that a dupe of bug #172648?

we've see the error message "ValueError: md0 is already in the mdList!" for
quite a few bugzillas and they should be resolved now. 

I'll mark this as duplicate if there's no response in reasonable amount of time.

Thanks.
Comment 32 Alexander Todorov 2008-06-04 03:28:32 EDT
Closing this bug as duplicate of bug #172648.

If you still have this issue please re-open.

*** This bug has been marked as a duplicate of 172648 ***

Note You need to log in before you can comment on or make changes to this bug.