Bug 1498045 - tenant source_id compromisation after changing provider credentials
Summary: tenant source_id compromisation after changing provider credentials
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: All
OS: All
high
medium
Target Milestone: GA
: 5.10.0
Assignee: Libor Pichler
QA Contact: Danylo Kholodov
URL:
Whiteboard:
Depends On:
Blocks: 1562772 1562773
TreeView+ depends on / blocked
 
Reported: 2017-10-03 11:42 UTC by Felix Dewaleyne
Modified: 2018-08-01 02:48 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1562772 1562773 (view as bug list)
Environment:
Last Closed: 2018-08-01 02:48:34 UTC
Category: Bug
Cloudforms Team: Openstack


Attachments (Terms of Use)

Description Felix Dewaleyne 2017-10-03 11:42:16 UTC
Description of problem:
tenant source_id compromisation after changing provider credentials

Version-Release number of selected component (if applicable):
5.8.1.5

How reproducible:
all the time

Steps to Reproduce:
1. Set credentials to 'openstackadmin' (from a 'custom' domain) and sync tenants.
2. Set credentials to 'admin' from 'default' domain and start ems refresh.
3. Revert credentials to 'openstackadmin' (because default admin does not see cinder cloud volumes from the 'custom' domain on CFME side).

Actual results:
Currently the ids of Cloud Tenants has changed but Tenant source_id does not updated accordingly and shows the old ID values to the cloud tenants

Expected results:
the tenant source_id is matched

Additional info:
changing back the credentials to what they were did not return the appliance to a normal state


Note You need to log in before you can comment on or make changes to this bug.