Bug 149808 - /etc/pam.d/login not updated by system-config-authentication
Summary: /etc/pam.d/login not updated by system-config-authentication
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-27 15:04 UTC by Philippe A
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 07:36:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Philippe A 2005-02-27 15:04:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I had a hard time having a Linux client authenticate against samba
with winbind. I eventually found it's because pam was not instructed
to auth with pam_winbind.so in /etc/pam.d/login. Would be great
system-config-authentication took care of that too!

Version-Release number of selected component (if applicable):
authconfig-4.6.5-3.1

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-authentication to enable winbind auth.
2. Have a look into /etc/pam.d/login
    

Actual Results:  /etc/pam.d/login has no reference to pam_winbind.so


Expected Results:  
#%PAM-1.0
auth       required     pam_securetty.so
auth        sufficient   pam_winbind.so
auth        sufficient   pam_unix.so use_first_pass
auth       required     pam_stack.so service=system-auth
auth       required     pam_nologin.so
account     sufficient   pam_winbind.so
account    required     pam_stack.so service=system-auth
password   required     pam_stack.so service=system-auth
# pam_selinux.so close should be the first session rule
session    required     pam_selinux.so close
session    required     pam_stack.so service=system-auth
session    optional     pam_console.so
# pam_selinux.so open should be the last session rule
session    required     pam_selinux.so multiple open


Additional info:

Comment 1 Tomas Mraz 2005-02-28 07:36:35 UTC
This is not right - authconfig updates only the system-auth file and
that's right - note that every other service stack file includes the
system-auth stack by calling the pam_stack.so. 
I suppose there is something wrong with your configuration if the
standard way doesn't work for you.



Note You need to log in before you can comment on or make changes to this bug.