Bug 1498081 - dht_(f)xattrop does not implement migration checks
Summary: dht_(f)xattrop does not implement migration checks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1471031 1530146 1540224
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-03 13:03 UTC by Shyamsundar
Modified: 2018-02-02 14:15 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.10.10
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1471031
Environment:
Last Closed: 2018-02-02 14:15:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2017-10-03 13:03:59 UTC
+++ This bug was initially created as a clone of Bug #1471031 +++

Description of problem:

Sharding uses xattrops to set the size info on the file. DHT does not currently implement migration phase1/phase2 checks for these and can possibly lead to issues when sharding is enabled.

Comment 1 Worker Ant 2018-01-10 07:57:23 UTC
REVIEW: https://review.gluster.org/19174 (cluster/dht: Add migration checks to dht_(f)xattrop) posted (#1) for review on release-3.10 by N Balachandran

Comment 2 Worker Ant 2018-01-30 18:37:19 UTC
COMMIT: https://review.gluster.org/19174 committed in release-3.10 by "N Balachandran" <nbalacha@redhat.com> with a commit message- cluster/dht: Add migration checks to dht_(f)xattrop

The dht_(f)xattrop implementation did not implement
migration phase1/phase2 checks which could cause issues
with rebalance on sharded volumes.
This does not solve the issue where fops may reach the target
out of order.

> Change-Id: I2416fc35115e60659e35b4b717fd51f20746586c
> BUG: 1471031
> Signed-off-by: N Balachandran <nbalacha@redhat.com>

Change-Id: I2416fc35115e60659e35b4b717fd51f20746586c
BUG: 1498081
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Shyamsundar 2018-02-02 14:15:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.10, please open a new bug report.

glusterfs-3.10.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-February/000090.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.