Bug 149812 - rc.sysinit does not rescan for volume groups after mdadm RAID initialization
rc.sysinit does not rescan for volume groups after mdadm RAID initialization
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 159795 (view as bug list)
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-02-27 11:43 EST by Ean J. Price
Modified: 2014-03-16 22:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-607
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 11:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ean J. Price 2005-02-27 11:43:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
rc.sysinit does not run vgscan after mdadm RAID initialization.  It does scan after raidtools initialization but raidtools is not present in RHEL4.

Version-Release number of selected component (if applicable):
initscripts-7.93.11.EL-1

How reproducible:
Always

Steps to Reproduce:
1.Create a RAID device and an /etc/mdadm.conf file
2.Mark the RAID device as a physical volume and create a volume group
3.Add an entry to /etc/fstab
4.Reboot and enjoy the sulogin goodness.
  

Actual Results:  Sulogin of doom when rc.sysinit got to the fsck.

Expected Results:  The VG should have started and then the fsck would not have errored out.

Additional info:

Here is the patch:

--- ./rc.sysinit.orig   2005-02-26 12:35:50.000000000 -0500
+++ ./rc.sysinit        2005-02-27 11:15:01.975030370 -0500
@@ -542,6 +542,13 @@
 update_boot_stage RCraid
 if [ -f /etc/mdadm.conf ]; then
     /sbin/mdadm -A -s
+
+    # LVM2 initialization, take 2 ( It could be on top of mdadm RAID )
+    if [ -c /dev/mapper/control -a -x /sbin/lvm.static ]; then
+        if /sbin/lvm.static vgscan > /dev/null 2>&1 ; then
+            action $"Setting up Logical Volume Management:" /sbin/lvm.static vgscan --mknodes --ignorelockingfailure && /sbin/lvm.static vgchange -a y --ignorelockingfailure
+        fi
+    fi
 fi
  
 if [ -f /etc/raidtab ]; then
Comment 1 Suzanne Hillman 2005-03-02 17:12:33 EST
Please attach patches rather than including them in comment fields.
Comment 2 Bill Nottingham 2005-03-02 17:34:29 EST
Currently fixed in CVS, targeted for U2.
Comment 3 Bill Nottingham 2005-06-08 11:24:38 EDT
*** Bug 159795 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2005-07-01 17:16:46 EDT
Fixed in 7.93.14.EL-1 for RHEL-4.
Comment 8 Red Hat Bugzilla 2005-10-05 11:47:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-607.html

Note You need to log in before you can comment on or make changes to this bug.