Bug 149816 - dhclient-3.0.1-40_FC3 failed to add default route
dhclient-3.0.1-40_FC3 failed to add default route
Status: CLOSED DUPLICATE of bug 149780
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-27 13:54 EST by H.J. Lu
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2005-02-27 13:54:46 EST
dhclient-3.0.1-40_FC3 failed to add the default route. I got

[hjl@gnu binutils]$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    
Use Iface
172.25.70.0     *               255.255.255.0   U     0      0        
0 eth0
169.254.0.0     *               255.255.0.0     U     0      0        
0 eth0

dhclient-3.0.1-30_FC3 works fine:

[hjl@gnu binutils]$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    
Use Iface
172.25.70.0     *               255.255.255.0   U     0      0        
0 eth0
169.254.0.0     *               255.255.0.0     U     0      0        
0 eth0
default         172.25.70.251   0.0.0.0         UG    0      0        
0 eth0

But on a different network, dhclient-3.0.1-40_FC3 works OK:

[hjl@gnu-d ~]$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    
Use Iface
10.3.194.0      *               255.255.255.0   U     0      0        
0 eth0
169.254.0.0     *               255.255.0.0     U     0      0        
0 eth0
default         10.3.194.251    0.0.0.0         UG    0      0        
0 eth0
Comment 1 Jason Vas Dias 2005-02-27 14:05:06 EST
In dhclient-3.0.1-40_FC3, the "GATEWAY" setting in ifcfg-ethX 
overrides the "routers" option sent by DHCP; if "GATEWAY" is
not on the same subnet as the IP address and subnet mask sent
by DHCP during configuration of ethX, no default route will be
created by the ethX configuration session. This is to permit
configuration of multiple interfaces with DHCP to work when the 
user wants to specify that only one GATEWAY should be used as
the default route, which may not be sent as any DHCP "routers" 
option (equivalent to specifying 'supersede routers $GATEWAY'
in /etc/dhclient.conf).
FIX: remove the "GATEWAY" setting from ifcfg-ethX 


*** This bug has been marked as a duplicate of 149780 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.