Bug 149824 - Erasing trailing newline in commands.getstatusoutput
Erasing trailing newline in commands.getstatusoutput
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-27 18:47 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 18:11:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-02-27 18:47:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1

Description of problem:
Not sure if this is a bug or a feature, but it looks like a bug.
This altering of the output breaks the SElinux genhomedircon command,
and causes pure chaos on my strict policy system.

--- commands.py 2005-02-27 18:42:23.000000000 -0500
+++ commands.new        2005-02-27 18:43:03.000000000 -0500
@@ -54,7 +54,6 @@
     text = pipe.read()
     sts = pipe.close()
     if sts is None: sts = 0
-    if text[-1:] == '\n': text = text[:-1]
     return sts, text


Version-Release number of selected component (if applicable):
python-2.4-4

How reproducible:
Always

Steps to Reproduce:
1. See summary
  

Additional info:
Comment 1 Ivan Gyurdiev 2005-03-01 18:11:08 EST
I was told this is a feature, and bug was resolved in selinux.
Closing.

Note You need to log in before you can comment on or make changes to this bug.