Bug 149831 - "xhdr newsgroups" lies
"xhdr newsgroups" lies
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: inn (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-27 23:23 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 12:13:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-02-27 23:23:33 EST
I've got inn-2.4.2-1.

"xhdr newsgroups" lies -- it doesn't return the actual Newsgroups
header of the article, but rather a list of newsgroups with all groups
that aren't available on the server stripped out.

This behavior is patently incorrect.  Just because a particular
newsgroup doesn't exist on my server doesn't mean it shouldn't be
preserved in the Newsgroups line when I follow up on a posting.  With
the behavior I described above, if my News reader uses xhdr to
determine the list of newsgroups to which the post a followup, which
it does in fact do and which is a perfectly reasonable thing to do,
it'll get it wrong.

As far as I'm concerned this is a violation of the NNTP spec.  The
xhdr command is supposed to return the actual message header, not the
header as INN chooses to pervert it.
Comment 1 ptomblin 2005-12-02 11:20:09 EST
It sounds like INN is trying to optimize the response by looking in the x-ref in
the overview rather than having to re-parse the article, because that's the
behaviour of x-ref.  You're right, that's a violation of RFC-2980.
Comment 2 Martin Stransky 2005-12-20 09:26:42 EST
Will be fixed in version 2.4.3...

Note You need to log in before you can comment on or make changes to this bug.