Bug 1498325 - no_proxy environment variable should be a standard format
Summary: no_proxy environment variable should be a standard format
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: kconner
QA Contact: Dongbo Yan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-04 01:56 UTC by Takayoshi Tanaka
Modified: 2017-10-25 21:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-25 21:01:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Issue Tracker CLOUD-2020 Major Verified [EAP7] no_proxy configuration not properly translated to maven settings 2019-02-21 07:27:48 UTC
Red Hat Issue Tracker CLOUD-2084 Major Verified no_proxy environment variable not properly translated to unix standard format 2019-02-21 07:27:48 UTC

Description Takayoshi Tanaka 2017-10-04 01:56:21 UTC
Description of problem:
Java s2i image requires "no_proxy" environment variable is a non-standard format like "*.foo.com,*.bar.com". This causes other tools (e.g. curl) not to work properly.
This specification is described here.
https://access.redhat.com/documentation/en-us/red_hat_jboss_middleware_for_openshift/3/html-single/red_hat_java_s2i_for_openshift/#configuration_environment_variables


Version-Release number of selected component (if applicable):
redhat-openjdk-18/openjdk18-openshift:1.1-11 
https://access.redhat.com/containers/?tab=overview#/registry.access.redhat.com/redhat-openjdk-18/openjdk18-openshift
and so on.

How reproducible:
Always

Steps to Reproduce:
1. Create a new app with s2i Java image under proxy server.
2. Set no_proxy like "no_proxy=*.google.com"

Actual results:
Failed to execute curl command.
$ curl http://www.google.com

Expected results:
Curl command executes without errors.

Additional info:

Comment 1 Ben Parees 2017-10-04 02:07:46 UTC
Kevin Conner's team owns this image, but they handle their issues in JIRA so he's likely going to want you to open it there.

Comment 2 Takayoshi Tanaka 2017-10-04 02:09:50 UTC
Could you tell me the JIRA URL?

Comment 3 Takayoshi Tanaka 2017-10-04 06:03:31 UTC
Though I'm not familiar with Java, will the below JIRA ticket fix this issue?
https://issues.jboss.org/browse/CLOUD-2020

Comment 4 Takayoshi Tanaka 2017-10-04 23:54:54 UTC
Since the previous JIRA ticket is not enough to fix this issue according to the customer , I file a new ticket.
https://issues.jboss.org/browse/CLOUD-2084

Comment 5 Ben Parees 2017-10-25 21:01:01 UTC
As this is not an openshift issue and the owning team tracks issues via JIRA, I am closing this bug.

Takayoshi, if you need a BZ to track this for the customer, please work w/ the middleware team to find a more appropriate BZ product/component to assign this to.


Note You need to log in before you can comment on or make changes to this bug.