Bug 1498426 - dnf download does not download RPMs in fedora rawhide container image
Summary: dnf download does not download RPMs in fedora rawhide container image
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1499255 1499293 (view as bug list)
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2017-10-04 09:46 UTC by Jun Aruga
Modified: 2017-10-17 10:37 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-10-08 08:27:22 UTC


Attachments (Terms of Use)

Description Jun Aruga 2017-10-04 09:46:05 UTC
Description of problem:

dnf download (dnf-plugins-core [1]) does not download target RPMs on Fedora rawhide docker container image on dockerhub. [2].
But it works on f26, f25 docker image.

Version-Release number of selected component (if applicable):

-bash-4.4$ rpm -q dnf-plugins-core dnf dnf-conf dnf-yum libdnf python3-dnf python3-hawkey
dnf-plugins-core-2.1.4-1.fc28.noarch
dnf-2.7.2-1.fc28.noarch
dnf-conf-2.7.2-1.fc28.noarch
dnf-yum-2.7.2-1.fc28.noarch
libdnf-0.10.1-2.fc28.x86_64
python3-dnf-2.7.2-1.fc28.noarch
python3-hawkey-0.10.1-2.fc28.x86_64


How reproducible:


Steps to Reproduce:
1. Use https://hub.docker.com/_/fedora/ rawhide docker image.
   I used this script to do "docker run". https://github.com/junaruga/rpm-py-installer/blob/master/.travis/run_docker_interactive.sh
   
2. docker run -it fedora:rawhide bash
3. [root@67014c76461c /]# dnf install 'dnf-command(download)'
4. [root@67014c76461c /]# useradd jaruga
5. [root@67014c76461c /]# su - jaruga

6. -bash-4.4$ rpm -q rpm-devel
package rpm-devel is not installed

-bash-4.4$ dnf download rpm-devel.x86_64
Last metadata expiration check: 0:20:44 ago on Wed Oct  4 09:18:28 2017.
rpm-devel-4.14.0-0.rc2.3.fc28.x86_64.rpm                      1.9 MB/s | 131 kB     00:00    
-bash-4.4$ ls
  => Empty.

7. -bash-4.4$ dnf download rpm-devel
Last metadata expiration check: 0:25:58 ago on Wed Oct  4 09:18:28 2017.
(1/2): rpm-devel-4.14.0-0.rc2.3.fc28.i686.rpm                 2.2 MB/s | 131 kB     00:00    
(2/2): rpm-devel-4.14.0-0.rc2.3.fc28.x86_64.rpm               2.2 MB/s | 131 kB     00:00    
-bash-4.4$ ls
  => Empty.


Actual results:
There was a message to download rpm-devel-4.14.0-0.rc2.3.fc28.x86_64.rpm in the result output.
But actually there is no RPM file in the directory after "ls".

Expected results:
Target rpm-devel-4.14.0-0.rc2.3.fc28.x86_64.rpm is downloaded in the current directory.


This issue is only for Fedora rawhide.
This works on F25, F26 docker image.


Additional info:
[1] https://github.com/rpm-software-management/dnf-plugins-core
[2] https://hub.docker.com/_/fedora/ rawhide.

Comment 1 Jun Aruga 2017-10-04 10:07:38 UTC
An another issue on the Fedora rawhide is

`dnf download rpm-devel.x86_64 --resolve` should download only not installed RPMs. That is a behavior on F25, F26.
But below command on Fedora rawhide might be trying to download including existed RPMs such as rpm-libs, rpm-build-libs.


-bash-4.4$ rpm -q rpm-libs
rpm-libs-4.13.90-0.git14002.8.fc28.x86_64

-bash-4.4$ rpm -q rpm-build-libs
rpm-build-libs-4.13.90-0.git14002.8.fc28.x86_64

-bash-4.4$ dnf download rpm-devel.x86_64 --resolve
Fedora - Rawhide - Developmental packages for the next Fedora  10 MB/s |  58 MB     00:05    
Last metadata expiration check: 0:00:23 ago on Wed Oct  4 10:02:17 2017.
(1/20): popt-devel-1.16-11.fc27.x86_64.rpm                    598 kB/s |  28 kB     00:00    
(2/20): ima-evm-utils-1.0-1.fc28.x86_64.rpm                   630 kB/s |  49 kB     00:00    
(3/20): rpm-devel-4.14.0-0.rc2.3.fc28.x86_64.rpm              1.3 MB/s | 131 kB     00:00    
(4/20): gc-7.6.0-7.fc27.x86_64.rpm                            2.0 MB/s | 110 kB     00:00    
(5/20): make-4.2.1-4.fc27.x86_64.rpm                          3.0 MB/s | 494 kB     00:00    
(6/20): libatomic_ops-7.4.6-3.fc27.x86_64.rpm                 1.1 MB/s |  33 kB     00:00    
(7/20): compat-openssl10-1.0.2j-9.fc28.x86_64.rpm             3.0 MB/s | 1.1 MB     00:00    
(8/20): libtool-ltdl-2.4.6-20.fc27.x86_64.rpm                 1.4 MB/s |  55 kB     00:00    
(9/20): libstdc++-7.2.1-1.fc28.x86_64.rpm                     2.4 MB/s | 461 kB     00:00    
(10/20): pkgconf-pkg-config-1.3.9-1.fc28.x86_64.rpm           545 kB/s |  13 kB     00:00    
(11/20): pkgconf-1.3.9-1.fc28.x86_64.rpm                      1.1 MB/s |  31 kB     00:00    
(12/20): pkgconf-m4-1.3.9-1.fc28.noarch.rpm                   777 kB/s |  13 kB     00:00    
(13/20): libpkgconf-1.3.9-1.fc28.x86_64.rpm                   1.2 MB/s |  31 kB     00:00    
(14/20): rpm-build-libs-4.14.0-0.rc2.3.fc28.x86_64.rpm        1.9 MB/s | 143 kB     00:00    
(15/20): rpm-4.14.0-0.rc2.3.fc28.x86_64.rpm                   3.1 MB/s | 529 kB     00:00    
(16/20): rpm-plugin-selinux-4.14.0-0.rc2.3.fc28.x86_64.rpm    1.5 MB/s |  65 kB     00:00    
(17/20): rpm-libs-4.14.0-0.rc2.3.fc28.x86_64.rpm              2.3 MB/s | 322 kB     00:00    
(18/20): rpm-plugin-systemd-inhibit-4.14.0-0.rc2.3.fc28.x86_6 1.4 MB/s |  66 kB     00:00    
(19/20): python3-rpm-4.14.0-0.rc2.3.fc28.x86_64.rpm           2.0 MB/s | 116 kB     00:00    
(20/20): guile-2.0.14-3.fc27.x86_64.rpm                       4.9 MB/s | 3.5 MB     00:00 

-bash-4.4$ ls
  => Empty

Comment 2 David Vásquez 2017-10-04 23:10:52 UTC
Same problem, in docker rawhide... dnf downloaded but the src.rpm is missed...


[root@0e336d0f80bd ffmpeg]# dnf --verbose download --source ffmpeg
Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.7.2
cachedir: /var/cache/dnf
enabling unitedrpms-source repository
enabling rawhide-source repository
repo: using cache for: unitedrpms
not found deltainfo for: unitedrpms 28 - x86_64
not found updateinfo for: unitedrpms 28 - x86_64
unitedrpms: using metadata from Wed Oct  4 02:58:15 2017.
repo: using cache for: unitedrpms-source
not found deltainfo for: unitedrpms 28 - Source
not found updateinfo for: unitedrpms 28 - Source
unitedrpms-source: using metadata from Wed Oct  4 02:58:35 2017.
repo: using cache for: enjoy
not found deltainfo for: enjoy
not found updateinfo for: enjoy
enjoy: using metadata from Wed Oct  4 20:16:39 2017.
repo: using cache for: rawhide
not found deltainfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
not found updateinfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
rawhide: using metadata from Tue Oct  3 16:02:23 2017.
repo: using cache for: rawhide-source
not found deltainfo for: Fedora - Rawhide - Source
not found updateinfo for: Fedora - Rawhide - Source
rawhide-source: using metadata from Wed Oct  4 08:56:12 2017.
Last metadata expiration check: 2:06:49 ago on Wed Oct  4 20:59:27 2017.
  --> Package : ffmpeg-3.3.4-3.fc28.x86_64 Source : ffmpeg-3.3.4-3.fc28.src.rpm
ffmpeg-3.3.4-3.fc28.src.rpm

[root@0e336d0f80bd ffmpeg]# ls
README.md  ffmpeg.spec

Comment 3 David Vásquez 2017-10-05 07:59:56 UTC
The problem appears with the updated version, in Fedora 25, 26, 27 and F28

dnf                         noarch 2.7.2-1.fc27          updates-testing 342 k 
dnf-conf                    noarch 2.7.2-1.fc27          updates-testing  67 k 
dnf-plugins-core            noarch 2.1.4-1.fc27          updates-testing  51 k 
dnf-yum                     noarch 2.7.2-1.fc27          updates-testing  49 k

Comment 4 Jun Aruga 2017-10-05 09:54:32 UTC
I wish that this issue's case is going to be added to the unit tests or integration tests.
https://github.com/rpm-software-management/dnf-plugins-core/tree/master/tests

Because my application is using "dnf download" as core function internally.

Comment 5 Jaroslav Mracek 2017-10-05 20:42:36 UTC
I created two patches that should solve the issue.
https://github.com/rpm-software-management/dnf-plugins-core/pull/235

https://github.com/rpm-software-management/dnf/pull/944

Comment 6 David Vásquez 2017-10-06 06:03:39 UTC
The patches only enable the download in mode --destdir? I am wrong? Then if I need download in the current directory, I need to specify the path?

Example:

dnf --verbose download --destdir $PWD --source yarock


I'll miss the default download...

Comment 7 Jaroslav Mracek 2017-10-06 06:22:34 UTC
No, the patches should restore functionality completely. Please if anyone could test it, that all functionality was restored, I would be very happy. (I can provide a copr repo on request with required release version)

Comment 8 David Vásquez 2017-10-06 06:27:20 UTC
Great! Also I can include me to test if you put a copr. Thanks

Comment 9 Jaroslav Mracek 2017-10-06 08:20:23 UTC
I create a copr repo with dnf and dnf-plugins-core patches  ( dnf copr enable jmracek/download ). Have a fun.

Comment 10 Richard W.M. Jones 2017-10-06 11:21:55 UTC
(In reply to Jun Aruga from comment #4)
> I wish that this issue's case is going to be added to the unit tests or
> integration tests.
> https://github.com/rpm-software-management/dnf-plugins-core/tree/master/tests
> 
> Because my application is using "dnf download" as core function internally.

I agree very much with this.  supermin depends on ‘dnf download’ and
it is too often broken in some way.

Comment 11 Jaroslav Mracek 2017-10-06 13:58:02 UTC
*** Bug 1499255 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2017-10-06 15:58:29 UTC
dnf-2.7.3-1.fc27 dnf-plugins-core-2.1.5-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bb3b9775cc

Comment 13 Fedora Update System 2017-10-06 15:58:59 UTC
dnf-2.7.3-1.fc26 dnf-plugins-core-2.1.5-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0f2730a8c2

Comment 14 Igor Gnatenko 2017-10-06 16:25:47 UTC
*** Bug 1499293 has been marked as a duplicate of this bug. ***

Comment 15 David Vásquez 2017-10-06 20:44:32 UTC
Tested the updated package in copr; failed. the problem is persistent.


[root@9f2521d464c1 yarock]# rpm -q dnf-plugins-core
dnf-plugins-core-2.1.4-1.git.606.d61f802.fc28.noarch
[root@9f2521d464c1 yarock]# rpm -q dnf
dnf-2.7.2-1.fc28.noarch
[root@9f2521d464c1 yarock]# dnf --verbose download --source yarock
Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.7.2
cachedir: /var/cache/dnf
enabling unitedrpms-source repository
enabling rawhide-source repository
repo: using cache for: unitedrpms
not found deltainfo for: unitedrpms 28 - x86_64
not found updateinfo for: unitedrpms 28 - x86_64
unitedrpms: using metadata from Wed Oct  4 02:58:15 2017.
repo: using cache for: unitedrpms-source
not found deltainfo for: unitedrpms 28 - Source
not found updateinfo for: unitedrpms 28 - Source
unitedrpms-source: using metadata from Wed Oct  4 02:58:35 2017.
repo: using cache for: jmracek-download
not found deltainfo for: Copr repo for download owned by jmracek
not found updateinfo for: Copr repo for download owned by jmracek
jmracek-download: using metadata from Fri Oct  6 08:18:14 2017.
repo: using cache for: rawhide
not found deltainfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
not found updateinfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
rawhide: using metadata from Wed Oct  4 08:56:56 2017.
repo: using cache for: rawhide-source
not found deltainfo for: Fedora - Rawhide - Source
not found updateinfo for: Fedora - Rawhide - Source
rawhide-source: using metadata from Wed Oct  4 08:56:12 2017.
Last metadata expiration check: 0:26:52 ago on Fri Oct  6 20:14:55 2017.
  --> Package : yarock-1.1.6-6.fc27.x86_64 Source : yarock-1.1.6-6.fc27.src.rpm
yarock-1.1.6-6.fc27.src.rpm                     185 kB/s | 728 kB     00:03    
[root@9f2521d464c1 yarock]# ls
[root@9f2521d464c1 yarock]#

Comment 16 David Vásquez 2017-10-06 21:40:48 UTC
mmm conflictive update...

Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 dnf-conf                    noarch 2.7.2-1.git.7959.35ff83b.fc28
                                                         jmracek-download 122 k
Skipping packages with broken dependencies:
 python2-dnf                 noarch 2.7.2-1.git.7959.35ff83b.fc28
                                                         jmracek-download 510 k

Comment 17 David Vásquez 2017-10-06 22:06:23 UTC
[root@9f2521d464c1 yarock]# dnf -y update --best --allowerasing
Last metadata expiration check: 2:48:00 ago on Fri Oct  6 18:53:31 2017.
Dependencies resolved.
================================================================================
 Package        Arch    Version                         Repository         Size
================================================================================
Upgrading:
 dnf            noarch  2.7.2-1.git.7959.35ff83b.fc28   jmracek-download  395 k
 dnf-automatic  noarch  2.7.2-1.git.7959.35ff83b.fc28   jmracek-download  120 k
 dnf-conf       noarch  2.7.2-1.git.7959.35ff83b.fc28   jmracek-download  122 k
 dnf-yum        noarch  2.7.2-1.git.7959.35ff83b.fc28   jmracek-download  103 k
 python3-dnf    noarch  2.7.2-1.git.7959.35ff83b.fc28   jmracek-download  506 k

Transaction Summary
================================================================================
Upgrade  5 Packages

Total download size: 1.2 M
Downloading Packages:
(1/5): dnf-conf-2.7.2-1.git.7959.35ff83b.fc28.n  68 kB/s | 122 kB     00:01    
(2/5): dnf-yum-2.7.2-1.git.7959.35ff83b.fc28.no  85 kB/s | 103 kB     00:01    
(3/5): dnf-2.7.2-1.git.7959.35ff83b.fc28.noarch 127 kB/s | 395 kB     00:03    
(4/5): dnf-automatic-2.7.2-1.git.7959.35ff83b.f 131 kB/s | 120 kB     00:00    
(5/5): python3-dnf-2.7.2-1.git.7959.35ff83b.fc2 117 kB/s | 506 kB     00:04    
--------------------------------------------------------------------------------
Total                                           286 kB/s | 1.2 MB     00:04     
warning: /var/cache/dnf/jmracek-download-f0d3901ff1cc195e/packages/dnf-2.7.2-1.git.7959.35ff83b.fc28.noarch.rpm: Header V3 RSA/SHA1 Signature, key ID 4fc56ae9: NOKEY
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Running scriptlet: systemd                                                1/1 
  Preparing        :                                                        1/1 
  Upgrading        : dnf-conf-2.7.2-1.git.7959.35ff83b.fc28.noarch         1/10 
  Upgrading        : python3-dnf-2.7.2-1.git.7959.35ff83b.fc28.noarch      2/10 
  Upgrading        : dnf-2.7.2-1.git.7959.35ff83b.fc28.noarch              3/10 
  Running scriptlet: dnf-2.7.2-1.git.7959.35ff83b.fc28.noarch              3/10 
  Upgrading        : dnf-yum-2.7.2-1.git.7959.35ff83b.fc28.noarch          4/10 
  Upgrading        : dnf-automatic-2.7.2-1.git.7959.35ff83b.fc28.noarch    5/10 
  Running scriptlet: dnf-automatic-2.7.2-1.git.7959.35ff83b.fc28.noarch    5/10 
  Running scriptlet: dnf-automatic-2.7.2-1.fc28.noarch                     6/10 
  Cleanup          : dnf-automatic-2.7.2-1.fc28.noarch                     6/10 
  Running scriptlet: dnf-automatic-2.7.2-1.fc28.noarch                     6/10 
Failed to connect to bus: No such file or directory
  Cleanup          : dnf-yum-2.7.2-1.fc28.noarch                           7/10 
  Running scriptlet: dnf-2.7.2-1.fc28.noarch                               8/10 
  Cleanup          : dnf-2.7.2-1.fc28.noarch                               8/10 
  Running scriptlet: dnf-2.7.2-1.fc28.noarch                               8/10 
  Cleanup          : python3-dnf-2.7.2-1.fc28.noarch                       9/10 
  Cleanup          : dnf-conf-2.7.2-1.fc28.noarch                         10/10 
  Running scriptlet: dnf-conf-2.7.2-1.fc28.noarch                         10/10 
Failed to connect to bus: No such file or directory
  Verifying        : dnf-2.7.2-1.git.7959.35ff83b.fc28.noarch              1/10 
  Verifying        : python3-dnf-2.7.2-1.git.7959.35ff83b.fc28.noarch      2/10 
  Verifying        : dnf-conf-2.7.2-1.git.7959.35ff83b.fc28.noarch         3/10 
  Verifying        : dnf-yum-2.7.2-1.git.7959.35ff83b.fc28.noarch          4/10 
  Verifying        : dnf-automatic-2.7.2-1.git.7959.35ff83b.fc28.noarch    5/10 
  Verifying        : dnf-2.7.2-1.fc28.noarch                               6/10 
  Verifying        : dnf-automatic-2.7.2-1.fc28.noarch                     7/10 
  Verifying        : dnf-conf-2.7.2-1.fc28.noarch                          8/10 
  Verifying        : python3-dnf-2.7.2-1.fc28.noarch                       9/10 
  Verifying        : dnf-yum-2.7.2-1.fc28.noarch                          10/10 

Upgraded:
  dnf.noarch 2.7.2-1.git.7959.35ff83b.fc28                                      
  dnf-automatic.noarch 2.7.2-1.git.7959.35ff83b.fc28                            
  dnf-conf.noarch 2.7.2-1.git.7959.35ff83b.fc28                                 
  dnf-yum.noarch 2.7.2-1.git.7959.35ff83b.fc28                                  
  python3-dnf.noarch 2.7.2-1.git.7959.35ff83b.fc28                              

Complete!
[root@9f2521d464c1 yarock]# dnf --verbose download --source yarock
Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.7.2
cachedir: /var/cache/dnf
enabling unitedrpms-source repository
enabling rawhide-source repository
repo: using cache for: unitedrpms
not found deltainfo for: unitedrpms 28 - x86_64
not found updateinfo for: unitedrpms 28 - x86_64
unitedrpms: using metadata from Wed Oct  4 02:58:15 2017.
repo: using cache for: unitedrpms-source
not found deltainfo for: unitedrpms 28 - Source
not found updateinfo for: unitedrpms 28 - Source
unitedrpms-source: using metadata from Wed Oct  4 02:58:35 2017.
repo: using cache for: jmracek-download
not found deltainfo for: Copr repo for download owned by jmracek
not found updateinfo for: Copr repo for download owned by jmracek
jmracek-download: using metadata from Fri Oct  6 08:18:14 2017.
repo: using cache for: rawhide
not found deltainfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
not found updateinfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
rawhide: using metadata from Wed Oct  4 08:56:56 2017.
repo: using cache for: rawhide-source
not found deltainfo for: Fedora - Rawhide - Source
not found updateinfo for: Fedora - Rawhide - Source
rawhide-source: using metadata from Wed Oct  4 08:56:12 2017.
Last metadata expiration check: 1:48:47 ago on Fri Oct  6 20:14:55 2017.
  --> Package : yarock-1.1.6-6.fc27.x86_64 Source : yarock-1.1.6-6.fc27.src.rpm
yarock-1.1.6-6.fc27.src.rpm                     358 kB/s | 728 kB     00:02    
[root@9f2521d464c1 yarock]# ls
yarock-1.1.6-6.fc27.src.rpm

Comment 18 Richard W.M. Jones 2017-10-07 17:10:37 UTC
It doesn't seem to work for me:

$ mkdir /var/tmp/p
$ dnf download --destdir=/var/tmp/p bash glibc
Last metadata expiration check: 0:39:05 ago on Sat 07 Oct 2017 17:30:24 BST.
$ echo $?
1
$ rpm -q dnf dnf-plugins-core
dnf-2.7.3-1.fc28.noarch
dnf-plugins-core-2.1.5-1.fc28.noarch

Note that no error is printed.

Comment 19 Richard W.M. Jones 2017-10-07 17:13:13 UTC
Except that if I enable --verbose then it works.

$ dnf --verbose download --destdir=/var/tmp/p bash glibc
Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.7.3
cachedir: /var/tmp/dnf-rjones-s5wo9gm2
repo: using cache for: rawhide
not found deltainfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
not found updateinfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
rawhide: using metadata from Fri 06 Oct 2017 09:59:03 BST.
Last metadata expiration check: 0:41:05 ago on Sat 07 Oct 2017 17:30:24 BST.
(1/3): bash-4.4.12-11.fc28.x86_64.rpm           1.1 MB/s | 1.5 MB     00:01    
(2/3): glibc-2.26.90-17.fc28.x86_64.rpm         1.1 MB/s | 3.4 MB     00:03    
(3/3): glibc-2.26.90-17.fc28.i686.rpm           1.0 MB/s | 3.2 MB     00:03

Comment 20 Fedora Update System 2017-10-08 06:23:14 UTC
dnf-2.7.3-1.fc27, dnf-plugins-core-2.1.5-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bb3b9775cc

Comment 21 Fedora Update System 2017-10-08 08:27:22 UTC
dnf-2.7.3-1.fc26, dnf-plugins-core-2.1.5-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Jun Aruga 2017-10-09 03:05:33 UTC
Thanks for the quick update.
I could check that is fixed on F27 and Fc26 container.

Comment 23 Fedora Update System 2017-10-10 19:30:10 UTC
dnf-2.7.3-1.fc27, dnf-plugins-core-2.1.5-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Jaroslav Mracek 2017-10-17 07:16:48 UTC
Additionally we have new test for download command to keep its functionality (ci-dnf-stack).

Comment 25 Richard W.M. Jones 2017-10-17 10:36:28 UTC
(In reply to Jaroslav Mracek from comment #24)
> Additionally we have new test for download command to keep its functionality
> (ci-dnf-stack).

This is great news, thanks.  Does the test run as both root and non-root?
In the past dnf download has failed in one case but not the other.

Comment 26 Richard W.M. Jones 2017-10-17 10:37:31 UTC
I should add that for supermin we mainly care about the non-root case.


Note You need to log in before you can comment on or make changes to this bug.