Bug 1498443 - AutoFS $host variable is replaced by the local hostname instead of the hostname of the server to be reached
Summary: AutoFS $host variable is replaced by the local hostname instead of the hostna...
Status: CLOSED DUPLICATE of bug 1497846
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: autofs
Version: 7.4
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: Filesystem QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-04 10:46 UTC by Davy Defaud
Modified: 2017-10-04 12:08 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2017-10-04 11:39:33 UTC


Attachments (Terms of Use)

Description Davy Defaud 2017-10-04 10:46:26 UTC
Since the update to CentOS 7.4 and autofs-5.0.7-69.el7, the special $host variable used in mount points is wrongly replaced by the local hostname instead of the remote server hostname hosting the shared filesystem to be mounted. All mounts using this $host variable were working perfectly with the previous release of autofs (5.0.7-56.el7).

Use case:
Content of /etc/auto.master.d/cifs.autofs:
/smb    /etc/autofs/auto.cifs

Content of /etc/autofs/auto.cifs:
* -fstype=autofs,-Dhost=& file:/etc/autofs/auto.cifs.sub

Content of /etc/autofs/auto.cifs.sub:
* -fstype=cifs,credentials=/etc/autofs/auto.cifs.${host}.secret,uid=${UID},gid=${GID},nounix,noserverino ://${host}/&

When I enable the debug mode, I can see that accessing to /smb/somesmbserver is now trying to mount the SMB shares of \\<myhostname> instead of \\somesmbserver.


Additional info:
Someone else has experienced the bug. See: https://www.centos.org/forums/viewtopic.php?t=64309

Comment 2 Ian Kent 2017-10-04 11:39:33 UTC
I think this is a duplicate of bug 1497846.

*** This bug has been marked as a duplicate of bug 1497846 ***

Comment 3 Davy Defaud 2017-10-04 12:08:54 UTC
Yes, indeed. It seems that I did not search enough for an existing bug report. Sorry.


Note You need to log in before you can comment on or make changes to this bug.