Bug 149846 - RHEL4: Add filtering for duplicate entries in netstat
Summary: RHEL4: Add filtering for duplicate entries in netstat
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-tools (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact: Ben Levenson
URL: IT_49181
Whiteboard:
Keywords:
Depends On: 139407
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-28 08:16 UTC by Jay Turner
Modified: 2015-01-08 00:09 UTC (History)
5 users (show)

Fixed In Version: RHBA-2005-242
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 12:48:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:242 normal SHIPPED_LIVE net-tools bug fix update 2005-06-09 04:00:00 UTC

Description Jay Turner 2005-02-28 08:16:42 UTC
+++ This bug was initially created as a clone of Bug #139407 +++

Description of problem:
 Client is experiencing duplicate entries in the output of netstat such as the
following:

netstat -a |grep piics2
tcp        0      0 hqias4:mtflocal         piics2:33135
ESTABLISHED
tcp        0      0 hqias4:mtflocal         piics2:33135
ESTABLISHED


The read() call on the /proc filesystem is, as Ben put it, best effort.  That
means that they try to make the data consistent, but it isn't always.  The
result is that sometimes two read() calls in /proc/net/tcp will return the same
entry because the kernel shuffles the table around in between the read() calls,
causing the duplicate entries that are reported in the bug.

Version-Release number of selected component (if applicable):
net-tools-1.60-19.AS21.1

How reproducible:
Problem occurs randomly, but with considerable frequency.

Steps to Reproduce:
1. run netstat -a
2. observe duplicate entries (identical lines)
3.
  
Actual results:
some lines may be displayed twice

Expected results:
no duplicate entries

Additional info:
This came from Morgan Stanley.

Comment 1 Radek Vokal 2005-02-28 08:26:28 UTC
Errata created 

Comment 2 Tim Powers 2005-06-09 12:48:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-242.html



Note You need to log in before you can comment on or make changes to this bug.