Bug 149847 - Ship copy of wtap.h so libwiretap is useful for development
Ship copy of wtap.h so libwiretap is useful for development
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ethereal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 04:02 EST by Valdis Kletnieks
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 09:07:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2005-02-28 04:02:13 EST
Description of problem:
third-party packages that use 'configure' to find Ethereal's libwiretap can't
use it without a copy of wtap.h

Version-Release number of selected component (if applicable):
ethereal-0.10.9-1

How reproducible:
The 'kismet' package (http://www.kismetwireless.net) can use the wiretap
library from Ethereal, but its 'configure' script can't find "wtap.h".

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Not clear if a wtap.h should go in the ethereal RPM, or if a separate
ethereal-devel RPM should carry it.
Comment 1 Radek Vokal 2005-02-28 09:07:19 EST
I don't think this is planned. The headers and libs should be included
in devel part of package but we don't ship ehtereal with -devel,
mainly because the ethereal libs changes way too often. 

Note You need to log in before you can comment on or make changes to this bug.