Bug 149850 - attempt to access beyond end of device
attempt to access beyond end of device
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 05:41 EST by Robert Vojta
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 10:20:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Vojta 2005-02-28 05:41:17 EST
Description of problem:

I was building OpenOffice.org from the CVS and I decided to check
used space (approximately about 10GB) via the 'du -s' command.
Few seconds later, aggressive disk access, I received lot of errors
from my desktop programs and build of OOo stops. The problem is in
this thing:

Feb 28 09:00:30 echelon kernel: attempt to access beyond end of device
Feb 28 09:00:30 echelon kernel: hda6: rw=0, want=13075849984, limit=75778542
Feb 28 09:00:30 echelon kernel: EXT3-fs error (device hda6): ext3_readdir:
directory #3042557 contains a hole at offset 0
Feb 28 09:00:30 echelon kernel: Aborting journal on device hda6.
...
[ hundreds of similiar message ]
...

Version-Release number of selected component (if applicable):

2.6.10-1.766_FC3

How reproducible:

Will try to reproduce tomorrow, when I'll backup everything
in my /home.
  
Actual results:

Data loss.

Expected results:

No data loss ...

Additional info:

Furnished upon request.
Comment 1 Stephen Tweedie 2005-02-28 12:32:32 EST
There's nothing to go on here.  You appear to have bad data on the disk; fsck
logs would be useful.  But unless it's reproducible, or you have additional
kernel logs, we can't tell if it's a hardware fault --- disk, cables, CPU or
memory; or a device driver, VM or filesystem problem.

memtest86 and a decent filesystem stresser such as "dt" would be good places to
start if you want to give the hardware a proper shakedown.
Comment 2 Robert Vojta 2005-02-28 12:45:33 EST
My laptop went through these stress tests before I installed FC,
all my computers are treated in this way.

I'll try to reproduce this tomorrow. If there will be no success,
I'll close this bug.
Comment 3 Dave Jones 2005-07-15 13:38:14 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Stephen Tweedie 2005-09-05 10:20:10 EDT
Closing as NOTABUG since there's still no indication whether this is hardware or
software as a root cause, and there has been no followup.  Please reopen if you
can reproduce this with more information against a current kernel.

Note You need to log in before you can comment on or make changes to this bug.