Bug 1498507 - ODL: opendaylight-6.1.0-2.el7ost contains upstream-provided .sos
Summary: ODL: opendaylight-6.1.0-2.el7ost contains upstream-provided .sos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Stephen Kitt
QA Contact: Itzik Brown
URL:
Whiteboard:
: 1498509 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-04 13:31 UTC by Stephen Kitt
Modified: 2018-10-18 07:21 UTC (History)
7 users (show)

Fixed In Version: opendaylight-6.2.0-4
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:37:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:38:54 UTC

Description Stephen Kitt 2017-10-04 13:31:31 UTC
As per https://errata.devel.redhat.com/rpmdiff/show/178505?result_id=4903242 the RPM contains .sos embedded in JARs. We need to ensure these are either rebuilt from source (as done for the leveldbjni JAR) or stripped.

Comment 2 Stephen Kitt 2017-10-16 16:04:55 UTC
This is fixed in http://pkgs.devel.redhat.com/cgit/rpms/opendaylight/commit/?h=rhos-12.0-rhel-7&id=fae1e5148bd8f0738401248c0cfa19912bc684b1 and building on https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14273174

The resulting RPM contains no embedded DSOs and the Karaf container works.

Comment 5 Lon Hohberger 2018-03-07 13:52:30 UTC
According to our records, this should be resolved by opendaylight-6.2.0-4.el7ost.  This build is available now.

Comment 8 Itzik Brown 2018-03-26 08:50:50 UTC
Checked with opendaylight-8.0.0-3.el7ost.noarch

In the /opt/opendaylight 

$ for jar in $(find . -name *.jar); do jar -tvf $jar | grep '.so$'; done
java.io.FileNotFoundException: ./system/org/fusesource/leveldbjni/leveldbjni-all/1.8-odl/leveldbjni-all-1.8-odl.jar (No such file or directory)
    at java.util.zip.ZipFile.open(Native Method)
    at java.util.zip.ZipFile.<init>(ZipFile.java:219)
    at java.util.zip.ZipFile.<init>(ZipFile.java:149)
    at java.util.zip.ZipFile.<init>(ZipFile.java:120)
    at sun.tools.jar.Main.list(Main.java:1115)
    at sun.tools.jar.Main.run(Main.java:293)
    at sun.tools.jar.Main.main(Main.java:1288)

Comment 9 Mike Kolesnik 2018-03-27 08:46:46 UTC
*** Bug 1498509 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-06-27 13:37:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.