Bug 1498545 - Downstream branding issues
Summary: Downstream branding issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Neha Gupta
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-04 15:21 UTC by Ju Lim
Modified: 2017-12-18 04:39 UTC (History)
8 users (show)

Fixed In Version: tendrl-ui-1.5.4-2.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
RHGS-WA Login (383.10 KB, image/png)
2017-10-04 15:21 UTC, Ju Lim
no flags Details
RHGS-WA Cluster List (48.12 KB, image/png)
2017-10-04 15:21 UTC, Ju Lim
no flags Details
RCUE Login Example (74.90 KB, image/png)
2017-10-04 15:22 UTC, Ju Lim
no flags Details
RCUE Application Example (56.88 KB, image/png)
2017-10-04 15:22 UTC, Ju Lim
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Ju Lim 2017-10-04 15:21:10 UTC
Created attachment 1334350 [details]
RHGS-WA Login

Description of problem:

• The login screen does not appear to have the correct spacing and is not using most recent version of RH Common User Experience (RCUE). Because the name is so long we could also scale it down in size. UXD provided SVG logos so there should be no loss in quality. You can see an example of the current RCUE login in the attached images. 

• For the application screen it appears like the logo used is the one which was sized for the login. The one UXD provided for the header is much smaller. If the one pictured is the header logo file then there are issues with scaling. You can see the attached screenshot to get an idea of the logo size. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Log into Tendrl UI, look at login page
2. Go to Cluster list page
3.

Actual results:
* The login screen does not appear to have the correct spacing and is not using most recent version of RH Common User Experience (RCUE)

* For the application screen it appears like the logo used is the one which was sized for the login.

Expected results:
* See attached RCUE examples

Additional info:

Comment 2 Ju Lim 2017-10-04 15:21:45 UTC
Created attachment 1334351 [details]
RHGS-WA Cluster List

Comment 3 Ju Lim 2017-10-04 15:22:10 UTC
Created attachment 1334352 [details]
RCUE Login Example

Comment 4 Ju Lim 2017-10-04 15:22:45 UTC
Created attachment 1334353 [details]
RCUE Application Example

Comment 5 Neha Gupta 2017-11-02 11:58:01 UTC
@julim@redhat.com Can you please tell us the specific standard dimensions to be used for logo on header page of the application. The RHSC2 was taking the "auto" width.

Comment 6 Ju Lim 2017-11-07 15:30:48 UTC
@ngupta

The logotype for the application header is using the wrong version. We had previously provided two versions, one for the masthead / header (small) and one for the Login screen (large). 

The provided logos were sized and labeled accordingly.  The login logo should be 18px tall, and the header logo should be 11px tall.

Comment 8 Bala Konda Reddy M 2017-11-20 07:02:39 UTC
Verified in tendrl-ui-1.5.4-3.el7rhgs.noarch

Created a new webadmin-server. Able to see redhat logo on the login page and on the header logo and once logged in to the web admin. Able to see "RED HAT GLUSTER STORAGE WEB ADMINISTRATION" on top left corner. No trace of tendrl seen on the login page.

Hence marking it as verified

Comment 11 errata-xmlrpc 2017-12-18 04:39:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.